Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Создать стек и подсчитать количество положительных элементов в нем

10-11 класс

HelpMyPliz 26 янв. 2016 г., 5:39:10 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Сool763
26 янв. 2016 г., 6:59:57 (8 лет назад)

Вот, на PascalABC.NET работает, думаю, на Турбе тоже пройдёт))

Type
    PComp = :stack;
    stack = record
      sD:real;
      pNext:PComp;
    end;
    
var
  pTop:PComp;
    
Procedure CreateStack(var pTop:PComp);
  begin
    New(pTop);
    pTop:.pNext:=nil
  end;
Procedure push(var pTop:PComp; var sC:real);
var
  pAux:PComp;
begin
  New(pAux);
  pAux:.pNext:=pTop;
  pTop:=pAux;
  pTop:.sD:=sC
end;
Procedure pop(var pTop:PComp; var sC:real);
begin
  sC:=pTop:.sD;
  pTop:=pTop:.pNext
end;

var
  i: real;
  j, k, l: integer;

begin
  CreateStack(pTop);
  writeln('Заполните стек числами. Признак конца ввода - 0');
  while (true) do
  begin
    readln(i);
    if (i = 0) then
      break
    else
      push(pTop, i);
    inc(j);
  end;
  
  for k := 1 to j do
  begin
    pop(pTop, i);
    if (i > 0) then
      l := l + 1;
  end;
  
  writeln(l);  
end.

+ 0 -
Lipina151999
26 янв. 2016 г., 8:47:33 (8 лет назад)

какой язык?

+ 0 -
Ilyaalien
26 янв. 2016 г., 10:43:10 (8 лет назад)

турбо паскать

+ 0 -
KatyaLadanova
26 янв. 2016 г., 12:41:25 (8 лет назад)

не,боюсь в паскале стек не потяну. на с++ бы сделал еще,извини

+ 0 -
Didika220920021
26 янв. 2016 г., 13:39:03 (8 лет назад)

Это ужасно(((

Ответить

Читайте также

Написать программу на Pascal ABC.Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов,

произведение и количество отрицательных элементов, произведение элементов до
первого отрицательного. Отсортировать массив по возрастанию.

1)Вывести в обратном порядке второе слово строки. Подсчитать количество букв в нем.

2) Составить программу для вычисления Т=(R/Q+1)+S. R - наименьший элемент массива;
Q - произведение элементов массива с нечетными номерами;
S - количество элементов, лежащих в интервале (A,B) (ввести с клавиатуры).
3) Вычислить среднее арифметическое положительных элементов матрицы, расположенных ниже
побочной диагонали. Закрасить указанные элементы.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Создать стек и подсчитать количество положительных элементов в нем", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.