Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Создайте программу в которой в одномерном массиве осуществляется поиск максимального, минимального элемента, подсчитывается количество отрицательных и

10-11 класс

количество положительных элементов.(паскаль)

Msninochka1999 18 нояб. 2014 г., 12:23:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
LedyGagaeeeee
18 нояб. 2014 г., 14:59:19 (9 лет назад)

Напишу сам цикл для нахождения минимального и максимального:
//counter - счетчик, Massive - массив, N - колво чисел в массиве

max := 0;
min := 100000;
for counter = 1 To N Do
    begin
    if Massive[counter] > max then max :=  Massive[counter];
    if Massive[counter] < min then min := Massive[counter];
writeln(min);
writeln(max);

Ответить

Другие вопросы из категории

Помогите срочно нужно пожалуйста
НАДО РЕШИТЬ В QBASIC

Спортсмен на тренировках в первый день пробежал 10 км. Каждый
следующий день он начал пробегать на 10% больше, чем в предыдущий день. Какой
суммарный путь пробежит спортсмен за 10 дней?

Решить задачи:

Задача 1. Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы.

Читайте также

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив. Задание 4. В одномерном массиве А[1..12]

необходимо поменять местами: а) первый и последний элементы массива; б) второй и минимальный элементы массива; в) третий и максимальный элементы массива; Вывести на экран исходный и результирующий массивы.

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "Создайте программу в которой в одномерном массиве осуществляется поиск максимального, минимального элемента, подсчитывается количество отрицательных и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.