Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПОМОГИТЕ Добрые люди. С клавиатуры вводятся дейстивительные числа и последовательно суммируются. Когда их сумма превысит 150, найти количество

10-11 класс

введенных чисел и их сумму. Через оператор FOR пожалуйста.

INGA758011 07 июля 2015 г., 8:17:01 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ane4ka03100
07 июля 2015 г., 10:24:12 (8 лет назад)

Через for разве что так:

var i,k:integer; a,s:real;
begin
s:=0; k:=0;
for i:=1 to 2 do begin read(a); s:=s+a; k:=k+1; i:=1; if s>150 then break end;
write(k,' ',s)
end.

+ 0 -
Wwwlenkaru89
07 июля 2015 г., 11:33:07 (8 лет назад)

Вы уверены, что через For? По условию больше бы While подошло.

+ 0 -
Lelya781
07 июля 2015 г., 14:19:02 (8 лет назад)

просто с for препод сказал сделать, не на зачет не пустит(

Ответить

Другие вопросы из категории

выразить 9мб в битах
ПОМОГИТЕЕЕ!!!

Программа для нахождения суммы n -введенных вещественных чисел.

Программирование. Даны три вещественных числа a,b,c. Существует ли треугольник со сторонами a,b,c? program dz1; uses crt; var

a,b,c:integer;

begin

writeln('введите три числа: ');

readln(a,b,c)

а дальше не знаю помогите пожалуйста!!!!)

Читайте также

Доброго времени суток, помогите пожалуйста с решением данной задачи, необходим код, для Turbo Pascal. Сама задача звучит так:

С клавиатуры вводится 3 числа, если сумма первого и последнего больше 10, то вывести эту сумму, если произведение больше 20, но меньше 30 (20>>30) то вывести это произведение, в противном случае вывести все эти 3 числа.

Требовалось написать программу,при выполнении которой с клавиатуры вводится натуральное число,не превосходящее 10^8, и выводится его первая цифра.Ученик

написал такую программу:
var n:longint;
begin
read(n);
while n>10 do
begin
n:=n mod 10
end;
write(n);
end.


1)Напишите,что выведет эта программа при вводе числа 1984.
2)Приведите пример числа,при вводе которого программа выдаст верный ответ.
3)Найдите в программе все ошибки.

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

1.пользователь вводит натуральное число. Определить среднее арифметическое цифр этого числа.

2.пользователь вводит натуральное число N. Найти сумму всех натуральных чисел от 1 до N.



Вы находитесь на странице вопроса "ПОМОГИТЕ Добрые люди. С клавиатуры вводятся дейстивительные числа и последовательно суммируются. Когда их сумма превысит 150, найти количество", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.