Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Исправьте код ,где ошибка ???

10-11 класс

дарианка 31 окт. 2015 г., 10:04:04 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivanpuskarev89
31 окт. 2015 г., 12:09:29 (8 лет назад)

возможно после if нужно поставить then и проверь 5 строчку, кажется там должно быть prinTf. А что за язык?=))

Ответить

Другие вопросы из категории

помогите пожалуйста,срочно
Всем привет :)

Помогите пожалуйста научиться решать задачи по типу:
Некто задумал натуральное число, не превосходящее 118, а затем сообщил: "Задуманное мною число является кратным числу 3". Какое количество бит информации содержится в этом сообщении?
Знаю про 2^i=N, но как это использовать?

Читайте также

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?

Где ошибка?? const n=10; type TMas=array[1..n] of integer; var mas1:TMas; procedure ImputMas1(var masTMas: integer);

var i: integer;

begin for i:=1 to 10 do

begin

mas1[i]:=random(n);

Write(mas1[i]:3);

end;

end.

Где ошибка?? const n=10; type TMas=array[1..n] of integer; var mas1:TMas; procedure ImputMas1(var masTMas: integer);

var i: integer;

begin for i:=1 to 10 do

begin

mas1[i]:=random(n);

Write(mas1[i]:3);

end;

end.

задача на Паскале. Подскажите, где ошибка?

Var A:array[1..6,1..6] of integer;

X:array[1..6] of byte;

i,j,n:byte;
sum:longint;

Begin

write('Введите кол-во строк N: ');
readln(n);

sum:=0;

For i:=1 to n do

Begin

For j:=1 to n do

Begin

write (vvedite matricy A[i,j]: ') ;

write(A[i,j]:4);

sum:=sum+A[i,j];

End;

if (A[i,i])>(A[i,j]) then x[i]:=0

else x[i]:=1;

writeln;

End;

writeln ('Полученный массив');

For i:=1 to n do

write(X[i]:2);

writeln;

writeln('сумма матрицы = ', sum);

readln;

End.

ГДЕ ОШИБКА??СКАЖИТЕ ПОЖАЛУЙСТА

ЗАДАНИЕ:ВЫЧИСЛИТЬ СУММУ ПЕРВЫХ 13 НАТУРАЛЬНЫХ ЧИСЕЛ КРАТНЫХ 5



Вы находитесь на странице вопроса "Исправьте код ,где ошибка ???", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.