Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1)Вычислить P=N!,где N вводится с клавиатуры с помощью трех видов цикла(1)repeat 2)while 3)For 2)модифицировать эти программы введя проверку N,если

10-11 класс

N>7,то вывести фразу"превышение допустимых значений" В другом случае подсчитать N!

Данонка31555 20 мая 2014 г., 1:19:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastiafomicheva
20 мая 2014 г., 3:00:47 (9 лет назад)

1)

program factorial;
var
a,n,i:integer;
begin
writeln('Вычисление факториала P=N!');
write('Введите значиние N: '); readln(n);
a:=0;
for i:=1 to n do a:=a+i;
writeln('P=', a);
end.

2)

program factorial;
var
a,n,i:integer;
begin
writeln('Вычисление факториала P=N!');
write('Введите значиние N: '); readln(n);
if n>7 then writeln('Превышение допустимых значений')
else
begin
a:=0;
for i:=1 to n do a:=a+i;
writeln('P=', a);
end;
end.

Ответить

Другие вопросы из категории

Написать подпрограмму, вычисляющую натуральную степень

числа. паскаль
написать программу на компьютере и проверить правильность
работы Вашей процедуры/функции, в этом случае в основной программе
должны быть реализованы ввод исходных данных и вызов
процедуры/функции.

Срочно!!!!

ввести натуральное число и определить, верно ли, что сумма цифр равна 10

Читайте также

СРОЧНО

Составьте программу, в которой функция выведет на экран однозначные числа, удовлетворяющие следующему условию: х*х*х-х*х=n , где n вводится с клавиатуры.

Ребятки помогите!!!! 1.Написать программу нахождения периметра треугольника .Значение сторон вводятся с клавиатуры. 2. Написать программу

нахождения S прямоугольного треугольника. ЗНАЧЕНИЯ КАТЕТОВ ВВОДЯТСЯ С КЛАВИАТУРЫ!

ПОМОГИТЕ ЗАЙКИ,,,,,

написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица

NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.



Вы находитесь на странице вопроса "1)Вычислить P=N!,где N вводится с клавиатуры с помощью трех видов цикла(1)repeat 2)while 3)For 2)модифицировать эти программы введя проверку N,если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.