Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать программу нахождения всех двузначных чисел, в которых есть цифра n.

5-9 класс

Lyubovignatova 26 мая 2014 г., 23:51:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zhen88
27 мая 2014 г., 0:46:42 (9 лет назад)

var n,i:integer;
begin
read (n);
if (n>=0) and (n<=9) then
begin
for i:=10 to 99 do
begin
if  (i mod 10=n) or (i div 10=n)  then writeln (i);
end;
end;
end.

Ответить

Другие вопросы из категории

помогите пожалуйста!!!задание по информатике(паскаль)

Составить программу описания двух переменных чисел:трех действительн., трех целых, трех постоянных ,целые(2 чиловые ,1 символьная)
на уроке успели только 1 пример сделать:
Program _ Zadacha _1 ;
const_ s1=3
pi=3.14;
var_c2,c1:integer;
b2:real;
begin
end.

Запишите

на языке Паскаль программу, которая вычисляет сумму кодов букв в слове БАЙТ.

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего – в куб и нахождения среднего

арифметического полученных значений.
2. За весну Обломов похудел на p1 кг, за лето поправился на p2 кг, за осень похудел на p3 кг, за зиму поправился на p4 кг. Написать программу, определяющую, похудел или поправился за год Обломов.
3. Написать программу, которая определяет, является ли целое число четным двузначным числом.
4. Даны коэффициенты квадратного уравнения. Написать программу, определяющую его корни

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "написать программу нахождения всех двузначных чисел, в которых есть цифра n.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.