Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ввести матрицу. Найти

10-11 класс

количество положительных k1 и k2 – отрицательных элементов. Если k1>k2, распечатать
положительные элементы матрицы, в ином случае – положительные элементы матрицы.
Срочно!

Drakylayra1 14 авг. 2014 г., 8:45:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wowa27072011
14 авг. 2014 г., 9:35:12 (9 лет назад)

var
  n,m,i,j,k1,k2: integer;
  a: array[1..100,1..100] of integer;

begin
  readln(n,m);
  for i:=1 to n do
    for j:=1 to n do readln(a[i,j]);
  for i:=1 to n do
    for j:=1 to n do
      if a[i,j]>0 then inc(k1) else inc(k2);
  for i:=1 to n do
    for j:=1 to n do
      if (k1>k2) and (a[i,j]>0) then writeln(a[i,j]) else
        if (k1<k2) and (a[i,j]<0) then writeln(a[i,j])
end.

Ответить

Читайте также

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1. Задать двумерный массив (10х10) по формуле, так чтобы значения элементов совпадали с номерами столбцов в квадрате.

2. Задать двумерный массив (4х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы.
3. Задать двумерный массив (7х7) случайными значениями от 12 до 18 включительно. В каждом столбце матрицы найти количество элементов, значения которых меньше 14.
4. Задать двумерный массив (3х3) с клавиатуры, поменять значения элементов 1 столбца со вторым.
5. Найти минимальный элемент матрицы (5х5), заданной случайными значениями от 1 до 5 включительно, лежащие ниже главной диагонали.

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали



Вы находитесь на странице вопроса "Ввести матрицу. Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.