Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В городе N-ске проходит конкурс на звание "Мистер большой живот". Побеждает тот, у кого объем талии больше всего. Помогите определить объем талии золотого

5-9 класс

и серебряного призера, если известно количество участников и объем талии каждого из них (все размеры талий различны)
Формат ввода N- кол-во участников Больше 3, меньше 100 А[1] объем талии первого участника А[N] объем талии N-ого участника (90<=А[N<=1000]).
Формпт вывода: два числа K1, K2 - объем талии золотого и серебрянного призера
Пример ввода 89 60 78 45 65 99 78
Пример вывода 99 89

Horsemoman 05 февр. 2014 г., 0:55:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
555387vano
05 февр. 2014 г., 2:54:51 (10 лет назад)

program gt;
var n,i,j,l:integer;
a:array[1..1000]of integer;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
for j:=1 to n-1 do
if(a[j]<a[j+1])then begin
l:=a[j];a[j]:=a[j+1];
a[j+1]:=l;
end;
writeln(a[1],' ',a[2]);
end.
Я просто отсортировал массив по убыванию методом пузырка

Ответить

Другие вопросы из категории

Пожалуйста, помогите составить блок-схему по

 \frac{1}{1+a} + \frac{1}{1+b} ... + \frac{1}{1+n}
И, пожалуйста, если сможете, с объяснением.
Заранее большое спасибо.с:

игра шиврофальщик выполните
Напечатайте

все нечетные числа от 3 до 25.

кросворд: 1. основной инструмент сбора , хранения и переработки 2.основное устройство ввода информации 3. "мозг"

компьютера

4..устройство ввода информации

5устройство хранения программ и данных

6.устройство для быстрого перемещения по экрану и выбора информации

7.носитель информации, на который записывают программы для хранения

8.другое название жёсткого диска

9.устройство, с помощью которого можно вывести на бумагу тексты и ресунки

Составить алгоритм сбора портфеля .

(оформление любое)

ПОМОГИТЕ !!!!

Читайте также

Определите,какой из представленных на рисунке кругов соответствует множеству:

а)"европейский город";
б)"город в Англии";
в)"столичный европейский город".



Перечислите города-объекты,являющиеся элементами представленных на рисунке множеств.

В результате реформы системы транспорта в городе были введены новые билеты на метро на

1, 5, 10, 15 и 20 поездок. В таблице ниже приведены стоимости билетов:
Количество поездок Цена билета
1 -35
5 -130
10 -170
15 -240
20 -300
Мише нужно совершить за месяц 44 поездки. Какие билеты и в каком количестве ему нужно
приобрести для этого? Он может купить билетов на большее число поездок, если это будет
выгоднее.
В ответе запишите 5 чисел через пробел: количество билетов на 1, 5, 10, 15, 20 поездок,
которое должен купить Миша. Например, ответ «3 0 1 0 2» означает, что Миша должен
купить 3 билета на 1 поездку, 1 билет на 10 поездок и 2 билета на 20 поездок.

написать прогу на паскале: у фигуристов проходит конкурс. Им присуждют баллы за 1-ю,2-ю и 3-ю программу катания. Найти средний балл всех трех программ

для каждого фигуриста, сумму балов для каждого фигуриста. Массив заполняется рандомом (желательно небольшие числа), кол-во фигуристов вводится с клавиатуры + найти победителя (максимальный средний балл)

Играют двое. Первый участник игры называет произвольное целое положи­тельное число, не превышающее десяти, то есть он может назвать число десять и всякое м

еньшее десяти положительное число. Второй игрок прибавляет к на­званному числу свое целое положительное число, также не превышающее десяти, и называет сумму. К этой сумме первый прибавляет какое-либо положительное число, не превышающее десяти, и сообщает сумму. Выигрывает тот, кто пер­вый достигнет ста.
Как добиться победы?



Вы находитесь на странице вопроса "В городе N-ске проходит конкурс на звание "Мистер большой живот". Побеждает тот, у кого объем талии больше всего. Помогите определить объем талии золотого", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.