Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

составьте программы на языке программирования для решения задачи : Число А вводиться с клавиатуры если оно положительно то извлечь из него квадратный

10-11 класс

корень иначе возвести его в квадрат результат вывести на экран

GlafiraAndrevna 24 авг. 2015 г., 19:51:03 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evi1Bot
24 авг. 2015 г., 22:13:06 (8 лет назад)

На языке Pascal
var   a,r:real;  

begin 
writeln('Введите число');
readln(a);   
   if a>0 then  
   begin     
     r:=sqrt(a);     
     writeln('r= ', r:6:3);   
   end     
 else   
  begin     
    r:=sqr(a);   
    writeln('r= ', r:6:3); 
  end;
end.

Ответить

Другие вопросы из категории

1)дан числовой массив из 10 чисел ( случайным образом) в интервале (50, 250) . Отсортировать массив.

2) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее арифметическое.
3) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

В одномерном массиве B, состоящем из 20 вещественных чисел, найтинаибольший элемент и указать его номер в массиве.

Составить схему алгоритма и программу на языке программированияBasic для решения задачи по обработке одномерного массива.

Напишите программу на языке Паскаль, для решения следующей задачи:

Для любого четырехзначного вводимого числа найти сумму второй и предпоследней цифры).
(Подсказка. Используйте тип данных integer и операции div и mod)

Напишите программу на языке паскадь для решения следущей задачи.

Известна площадь квадрата. Найдите периметр и диагональ квадрата



Вы находитесь на странице вопроса "составьте программы на языке программирования для решения задачи : Число А вводиться с клавиатуры если оно положительно то извлечь из него квадратный", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.