Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ОЧЕНЬ СРОЧНО НУЖНО СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ:введите с клавиатуры три числа: А,В,С. если А > В > С > 0,то замените все числа их

10-11 класс

квадратами и выведите результаты на экран. если они отрицательные и не равные между собой,то каждое число замените наибольшим из них и выведите результаты. иначе ,найдите и выведите их сумму.

Vipkivanova 26 авг. 2016 г., 1:53:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bingib
26 авг. 2016 г., 2:56:03 (7 лет назад)

var

  a, b, c, m : integer;

begin

  if (a > 0) and (b > 0) and (c > 0) and (a > b) and (b > c) then

  begin

    a := sqr (a);

    b := sqr (b);

    c := sqr (c);

  write (a, ' ', b, ' ', c);

  end

  else if (a < 0) and (b < 0) and (c < 0) and (a <> b) and (c <> a) and (b <> c) then

  begin

    m := a;

    if b > m then m := b;

    if c > m then m := c;

    a := m;

    b := m;

    c := m;

write (a, ' ', b, ' ', c);

end

else writeln (a + b + c);

end.

Ответить

Другие вопросы из категории

11.Сообщение занимает 3

страницы по 25 строк. В каждой строке записано по 60 символов. Сколько символов
в этом алфавите, если все сообщение содержит 1125 байт?

12.Автоматическое
устройство осуществило перекодировку информационного сообщения на русском
языке, первоначально записанного в 16-битном коде Unicode, в 8-битную кодировку
КОИ-8. При этом информационное сообщение уменьшилось на 480 бит. Какова
длина сообщения в символах?

Помогите решить задачку.

Читайте также

Помогите срочно!

Составить алгоритм через паскаль.Введите с клавиатуры три числа авс.если а=в.то все числа замените квадратами если а>b>c то каждое число замените наибольшим, иначе: а сделайте равным сумме в и с, с обнулите, в оставьте без изменения»

Составить программу на языке паскаль

задание: дана матрица А(N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

нужно составить программу в паскале

Царевна-лягушка съедает ежедневно на 20 % комаров больше, чем в предыдущий день, и еще 2 комара. Через сколько дней количество съеденных комаров в день превысит 100, если в первый день было съедено 12 комаров.

Воспользуйтесь словесным алгоритмом.
1)i:= 1
2)s:=12
3)если s<=100, то п.4, иначе 6
4)i:=i+1
5)s:=1.2*s+2, перейти к п.3
6)вывод i
7)конец



Вы находитесь на странице вопроса "ОЧЕНЬ СРОЧНО НУЖНО СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ:введите с клавиатуры три числа: А,В,С. если А &gt; В &gt; С &gt; 0,то замените все числа их", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.