Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел должно задаваться во

5-9 класс

время работы программы. (цикл для)(паскаль )

Fulfil 23 мая 2013 г., 18:06:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sofiechka
23 мая 2013 г., 19:01:36 (10 лет назад)

var
  i, count : integer;
  summ, temp : real;
begin
  summ := 0;
  readln(count);
  for i := 1 to count do
  begin
    readln(temp);
    summ := summ + temp;
  end; 
  writeln(summ / count);
end.

+ 0 -
Mikeha
23 мая 2013 г., 19:50:56 (10 лет назад)


Program Nooobodyyy;
uses crt;
var
  i,how:integer;
  ch,appr,sum:real;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N дробных чисел и находит их среднее арифметическое');
  sum:=0;
  write('Введите количество чисел: '); readln(how);
  for i:=1 to how do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
    end;
  appr:=sum/how;
  writeln('Cреднее арифметическое равно ',appr:8:2);
end.

Ответить

Другие вопросы из категории

помогите с информатикой найдите лишнее слово Клавиатура, джойстик, сканер, принтер. Монитор, графопостроитель, принтер, мышь.

Жесткий диск, flash-память, компакт-диск, процессор.

Принтер, акустические колонки, наушники, микрофон.

Системный блок, центральный процессор, оперативная память, жесткий диск, блок питания.

Системный блок, клавиатура, мышь, монитор, акустические колонки.

Видеокарта, карта расширения, звуковая карта, сетевая карта.

Enter, End, Esc, Delete.

Цветной принтер, лазерный принтер, матричный принтер, струйный принтер.

4433(8) перевести в десятичную
Средняя скорость передачи данных по некоторому каналу связи равна 29 Кбит/с. Сколько секунд потребуется для передачи по этому каналу 50 страниц текста,

если считать, что один символ кодируется одним байтом и на каждой странице в среднем 96 символов?

Читайте также

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

НАПИШИТЕ ПРОГРАММУ В ПАСКАЛЕ, СРОЧНО !!

написать программу, которая вычисляет среднее арифметическое ненулевых элементов массива M[1..100], элементы которого вычисляются по формуле M[i]=sin(i)*cos(i)

и прошу не используйте интернет, а напишите сами по возможности.

1. Написать программу, которая спрашивает «Который час?» и, в зависимости от введенного времени, выводит на экран приветствие: «Доброе утро», «Добрый

день», «Добрый вечер», «Спокойной ночи».
2. Составьте программу, которая вычисляет оптимальный вес пользователя, сравнивает его с реальным весом и выдает рекомендации о необходимости поправиться или похудеть. Оптимальный вес вычисляется по формуле: рост (в сантиметрах) – 100.
Помогите решить 2 задачи

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).



Вы находитесь на странице вопроса "Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел должно задаваться во", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.