Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В одномерном вещественном массиве подсчитать сумму всех элементов, больших заданного числа.

10-11 класс

Kosha07 08 нояб. 2016 г., 22:57:20 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mersy250700
08 нояб. 2016 г., 23:39:14 (7 лет назад)

// Массив генерируется случайным образом

// Есл ввод массива нужен с клавиатуры то вместо a[i]:=random... Поставишь readln(a[i]); 

 

 

Program Massiv;

Uses Crt;

const n=10; {размер массива ,если нужно больше поставишь другое число}

var a:array[1..n] of real;

       s,x:real;

       i:integer; 

begin

     clrscr;

      write('Введите число x : ');

       readln(x);

     randomize; 

     s:=0;

     write('Исходный массив: ');    

     for i:=1 to n do

        begin  

           a[i]:=random(101)/3;  

 

            if (a[i]>x) then s:=s+a[i];

             write(a[i]:3:3,'  '); 

        end; 

    writeln;

     writeln('Сумма элементов больших ',x,'=',s);

 

      readkey; 

end. 

 

 

 

 

 

 

Ответить

Другие вопросы из категории

Выберите фрагмент программы , в котором переменной У присваивается значение, равное 0,если -5<X<5. в противном случае переменной У присваивается

значение равное 1.

а) IF X<5 OR X>-5 THEN Y=0 ELSE Y=1

б) IF X<5 AND X>-5 THEN Y=0 ELSE Y=1

в) IF X<5 THEN IF X>-5 THEN Y=1 ELSE Y=0

г) IF X<5 AND X>-5 THEN Y=1 ELSE Y=0

Читайте также

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

помагите пжл, составить программу на языке ПАСКАЛЬ СОСТАВИТЬ ПРОГРАММУ СОКРАЩЕНИЯ ОДНОМЕРНОГО ЧИСЛОВОГО МАССИВА ПУТЕМ УДАЛЕНИЯ ( ВСЕХ ЭЛЕМЕНТОВ С НУЛЕВЫ

МИ ЗНАЧЕНИЯМИ . ДОПОЛНИТЕЛЬНЫЙ МАССИВ ИСПОЛЬЗОВАТЬ НЕ РАЗРЕШАЕТСЯ ) .........ЕСЛИ МОЖЕТИ ПОЯСНИТЕ СЛОВАМИ ЧТО ДЕЛАЕТ ПРОГРАММА



Вы находитесь на странице вопроса "В одномерном вещественном массиве подсчитать сумму всех элементов, больших заданного числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.