Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Любое не однозначное число вводится с клавиатуры . Если это число делится на цифру самого младшего разряда в этом числе, то это число выводится на

10-11 класс

экран. В Паскале

Flimpflamp 16 апр. 2013 г., 10:01:17 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Koteika7771
16 апр. 2013 г., 11:15:10 (11 лет назад)

program gt;
var n,a,q:integer;
begin
read(n);
a:=n mod 10;
if(n mod a=0)then writeln(n);
end.

Ответить

Другие вопросы из категории

Найдите лишнее:

САПР
Текстовый процессор
Отладчик
Microsoft Access
Графический редактор

помогите срочно,пожалуйста решить

2,3,5,6

1) Заполнить и вывести на экран массив 5 х 10 случайных целых чисел в диапазоне от 1 до 10. 2) Найти сумму элементов одномерного массива с k1-го

по k2-ой, где k1 и k2 вводятся с клавиатуры. Сделать проверку корректности их ввода.

3) Найти сумму всех элементов одномерного массива, имеющих четные индексы.

4) Создать одномерный массив случайных целых чисел в диапазоне (-7,2). Переставить в обратном порядке элементы массива.

5) Найти 3 минимальных элемента массива и возвести их в квадрат.

Читайте также

Удвоить трѐхзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае.

Если введѐнное число не трѐхзначное, вывести сообщение об ошибке.(В ПАСКАЛЕ)

Помогите пожалуйста с информатикой.Программировани

е на quick basic.

1. Составить программу вычисления значений двух выражений W и Q, учитывая одз (знаменатель не может быть равен нулю, под корнем не может быть отрицательного числа).Если какое-то выражение вычислить нельзя, вывести об этом сообщение, иначе -числовой ответ, используя ФОРМАТНЫЙ ВЫВОД. Все переменные вводятся с клавиатуры. Выражения
W= квадр.корень из x+12 делить на 2x^3+2
Q = квадр.корень из sin a+3+a делить на a^3 +квадр.корень из sin a +3

2. Даны два числа (вводятся с клавиатуры). Меньшее заменить полусуммой, а большее -удвоенным произведением. Предусмотреть случай их равенства, вывести об этом сообщение.

№1 Определите количество пассажиров, которые могут поместиться на борт самолёта грузоподъемностью 8т(вес каждого пассажира вводится с клавиатуры).

№2 Начальный вклад в сберкассу составил А руб. Через сколько лет удастся накопить В руб. без учета дополнительных вкладов, если каждый год вклад увеличивается на 3%.

№3 Определите число суток с 1900 по 1999 года, если известно, что високосные годы - это те, у которых номер делится на 400 или те, у которых номер делится на 4, но не делится на 100.

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )



Вы находитесь на странице вопроса "Любое не однозначное число вводится с клавиатуры . Если это число делится на цифру самого младшего разряда в этом числе, то это число выводится на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.