Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать програму для обчислення добутків виду (х-1)(х-2)(х-3)...(х-n) (P.S скласти програму и блок схему)

10-11 класс

Lerf00w 31 марта 2017 г., 12:29:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Elena9921
31 марта 2017 г., 13:21:40 (7 лет назад)

var

i,n,x:integer;

p:longint;

begin

write ('X = ');readln(x);

repeat

write ('N = ');readln(n); 

until (n>0);

p:=1; 

for i:=1 to n do p:=p*(x-i);

writeln ('Proizvedenie: ',p);

readln;

end.

Ответить

Другие вопросы из категории

помогите срочно,пожалуйста решить

2,3,5,6

1) Заполнить и вывести на экран массив 5 х 10 случайных целых чисел в диапазоне от 1 до 10. 2) Найти сумму элементов одномерного массива с k1-го

по k2-ой, где k1 и k2 вводятся с клавиатуры. Сделать проверку корректности их ввода.

3) Найти сумму всех элементов одномерного массива, имеющих четные индексы.

4) Создать одномерный массив случайных целых чисел в диапазоне (-7,2). Переставить в обратном порядке элементы массива.

5) Найти 3 минимальных элемента массива и возвести их в квадрат.

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

Создать блок схему для следующей задачи (разветвленный алгоритм): Ввести с клавиатуры число (любое). Если число положительно, то нарисовать круг. Если

отрицательное или равно 0 - закрашенный прямоугольник помогите плиз написать программу для QBASIC

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s







Вы находитесь на странице вопроса "Написать програму для обчислення добутків виду (х-1)(х-2)(х-3)...(х-n) (P.S скласти програму и блок схему)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.