Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С помощью оператора цикла со счетчиком найти среднее арифметическое из n целых нечетных чисел. пожалуйста очень надоооо** 8 класс

5-9 класс

Erevanerevan11 24 авг. 2013 г., 18:16:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Криштопов
24 авг. 2013 г., 19:32:17 (10 лет назад)

Вот вариант если надо найти среднее арифметическое из n нечётных чисел начиная от единицы.

На паскале:

 

program test;
var total:real; i, n:integer;
begin
  write('Enter n: ');
  readln(n);
  total := 0;
  write('(');
  for i := 1 to (n + n) do
  begin
    if i mod 2 <> 0 then
      begin
        total := total + i;
        write(i);
        if i < (n + n - 1) then
          write(' + ');
      end;
  end;
  total := total / n;
  writeln(') / ', n, ' = ', total:0:1);
readln();
end.

 

Работает примерно так:

Пользователь вводит количество нечётных чисел(например 5)

Дальше программа считает сумму первых пяти нечётных чисел начиная с единицы и одновременно выводит их

Дальше проиходит деление этой суммы на n(находится среднее) и вывод результата деления

+ 0 -
Sam4ik28
24 авг. 2013 г., 20:10:38 (10 лет назад)

1 ввести n  (если не натуральное - запросить заново)

2 открываем цикл

3 вводим n-ое число (если нечетное или нецелое - запросить заново)

4 S=S+n

5 закрываем цикл

6 S/n

где S - сумма чисел

 

(я не понял на каком языке это надо написать)

Ответить

Другие вопросы из категории

Как работает цикл?

Что будет если конечное значение счетчика будет меньше начального?
Что происходит с циклом если значение шага отрицательно?

Помогите решить!

1)))Вводятся 4 числа: a, b,

Задача.

На компакт-диске 600 Мбайт размещен фотоальбом. Каждое фото занимает 500 Кбайт.
Сколько времени нужно на просмотр всех фотографий если на одну тратить 6 сек?
С решением пожалуйста)

Читайте также

Составить программу на Паскале

Найти среднее арифметическое трѐх целых случайных чисел,
принадлежащих промежутку [0; 10).

найти сумму 10 чисел вводимых с клавиатуры через цикл со счетчиком

нужна блок-схема и сама программа



Вы находитесь на странице вопроса "С помощью оператора цикла со счетчиком найти среднее арифметическое из n целых нечетных чисел. пожалуйста очень надоооо** 8 класс", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.