Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Нужно составить нормальный алгоритм Маркова! Алфавит ABCD. Заменить каждый чётный элемент на C и каждый 4ый на D.

10-11 класс

Zhansaikaxd 03 янв. 2015 г., 17:32:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mega25artem
03 янв. 2015 г., 20:18:37 (9 лет назад)

Program Markov;
uses crt;
var a:string; i,b:integer;
begin
Clrscr;
writeln('Введите слово ');
read(a);
b:=length(a);
for i:=1 to b do begin
If i mod 4 = 0 then
begin
delete(a,i,1);
insert('D',a,i);
end else
If i mod 2 =0 then begin
delete(a,i,1);
insert('C',a,i);
end;

end;

writeln(a);
readln;
end.

Ответить

Другие вопросы из категории

задача на фото плз решите
ребята очень срочно надо!

надо написать программу

Срочно нужна помощь с написанием программы. "Генератором случайных чисел (от 0 до 100) задан массив из 26 целых чисел. Составьте программу, с помощью

которой сначала напечатайте элементы массива в строчку, а на следующей строчке - произведение элементов с чётными индексами". Заранее спасибо.

Читайте также

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "Нужно составить нормальный алгоритм Маркова! Алфавит ABCD. Заменить каждый чётный элемент на C и каждый 4ый на D.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.