Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите решить в паскале!!!

5-9 класс

Даны пять чисел,
каждое из которых по модулю не превышает ста. Вычислить максимум среди
отрицательных из них.

ХАЛЬЧ 20 авг. 2013 г., 9:11:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ФЫВАроормт
20 авг. 2013 г., 10:07:54 (10 лет назад)

var a:array[1..5] of real;
b,c:integer;
max:real;
begin
c:=0;
max:=-100;
writeln('Введите числа');
for b:=1 to 5 do
begin
readln(a[b]);
if (a[b]<0)and (a[b]>max) then begin
max:=a[b];
c:=c+1;
end;
end;
if c>0 then writeln('Максимум среди отрицательных чисел равняется ',max)
else writeln('Нет отрицательных чисел');
end.

Ответить

Другие вопросы из категории

1)как можно описать в паскале массив в котором будут хранится значения численности населения Москвы к концу каждого года 20 века.2) Вы приобрели

котенка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будут хранится значения веса котенка в течение мая.3)На основе этих заданий надо составить фрагмент программы на Паскале ввода исходных данных для массивов.

Ответьте хотя бы на то, что знаете: Вопросы в кроссворде: Вопросы в кроссворде:

1. Компютерная сеть, объеденяющая многие локальные сети. (10 букв)
2. Высокопрофесиональный программист. (5 букв)
3. Компютер абонента сети. (8 букв)
4. Способ организации текстовой информации, внутри которой установленны смысловые связи. (10 букв)
5. Обмен информацией по глобальной компютерной сети. ( Аж 16 букв!)

Читайте также

ПОМОГИТЕ!!!удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.если таких элементов несколько ,

удалить последний из найденных.Помогите решить в паскале.(вычислить средн.ариф.номер э-та,....)

помогите решить в Паскале
Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.



Вы находитесь на странице вопроса "Помогите решить в паскале!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.