Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Pascal. Создать процедуру, которая может найти дискриминант квадр. уравнения по введённым коэффициентам.

5-9 класс

Yakovlevalizoc 18 июля 2014 г., 5:09:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mainik1111
18 июля 2014 г., 7:53:09 (9 лет назад)

на pascal abc

uses  crt;
    var 
    a,b,c,d,x1,x2,x : real;
begin  
   write ('Введите a,b,c:'); 
   readln (a,b,c); 
   d:=b*b-4*a*c; 
   if d > 0 then
      begin           
      x1:=(-b+sqrt(d))/2*a;           
      x2:=(-b-sqrt(d))/2*a;           
      writeln ('x1= ', x1:1:3,' ', 'x2= ', x2:1:3)           
      end 
   else if d = 0 then begin               
    x:=-b/2*a;               
   writeln ('x= ', x);               
  end 
else if d < 0 then                
writeln ('Корней нету');
end.

Ответить

Другие вопросы из категории

Напишите пожалуйста программу на abc pascal:

1. Массив из 10 элементов, которые равны: 1,2,3,...100.
2.Массив из 10 элементов, которые равны: 1,4,9,16,...100.(подсказка-это квадраты чисел)

ПОмогите!!!.мои подруги решили угадать пароль от моего телефона.гадали долго,и телефон написал,что слишком много было попыток.надо ввести емейл и пароль.я

не помню пароль.на компе я зашла в аккаунт и поменяла пароль.ввела на телефоне,а он не принимает и пишет,что указано неверно(проверяла по тысяче раз каждую буковку,все правильно!!)Умоляю!телефон не включается,а выходит только это окно.

7. 100 шестиклассников нашей школы участвовали в опросе, в ходе которого выяснилось, какие компьютерные игры им нравятся больше: симуляторы, квесты или

стратегии. В результате 20 опрошенных назвали симуляторы, 28 - квесты, 12 – стратегии. Выяснилось, что 13 школьников отдают предпочтение симуляторам и квестам, 6 учеников – симуляторам и стратегиям, 4 ученика – квестам и стратегиям, а 9 ребят совершенно равнодушны к названным компьютерным играм. Некоторые из школьников ответили, что одинаково увлекаются и симуляторами, и вестами, и стратегиями. Сколько таких ребят?

Щелчком на кнопке открывается главно меню

Что надо вставить в пропуске?

Читайте также

Исполнитель Чертёжник действует на координатной плоскос­ти. У него есть перо, которое может быть поднято или опущено. При поднятом пере Чертёжник просто

перемещает­ся по плоскости; при опущенном — оставляет след в виде линии. Исполнитель может выполнять команды:
1) сместиться в точку (а, b), перемещающую Чертёжника из точки с координатами (х, у) в точку с координатами (а, b);
2) сместиться на вектор (а, b), перемещающий Чертёжника из точки с координатами (х, у) в точку с координатами (x+а, у+b).
Для повторения k раз некоторой последовательности команд используется запись:
нц к раз
команда1 команда2 командаЗ
кц
а) Определите, что будет нарисовано после выполнения Чертёжником программы:

поднять перо
сместиться в точку (3, 1)
опустить перо
сместиться на вектор (2, 0)
сместиться на вектор (1,1)
сместиться на вектор (-4, 0)
сместиться в точку (3,1)
поднять перо
сместиться на вектор (1,1)
опустить перо
сместиться на вектор (0, 3)
сместиться на вектор (1, -2)
сместиться на вектор (-1, -1)

1.Меню настройки в графическом редактаре.? 2.Последовательность действий (план) для решения какой-либо задачи.? 3.Устройства вывода

информации,без которого пользователь оказывается "слеп".?

4.Результат работы в графическом редакторе.?

5.Элемент управления мышью,который можно найти и на Рабочем столе кампьютера.?

6.Термин в графическом редакторе, которым называются изменяемые свойства рисунка- длина, ширина , цветность (смотри меню Рисунок).?

7.Мельчайший элемент компьютерного рисунка.?

8.Что такое компьютер: думающие устройство или автомат,строго выполняющий написаные человеком програмы ? Выбери одно из выделены слов.

9.Какое свойство рисунка позволяет улучить в гравическом редакторе инструмент Масштаба,

прошу ответе побыстрее и пишите номер ответа на который вы отвечаете и отвечайте на какие можете

Вариант 19 Световое табло каждая из которых может находиться в двух состояниях состоит из лампочек, на квключено» или«выключено» какое наименьшее

количество лампочек должно находить табло, чтобы можно было передать 64 различных сигнала? с его помощью метеорологическая станция ведет наблюдение за температурой воздуха считается, что температура должна быть представлена целым числом при этом она не может опускаться ниже выше плюс 25 градусов каждое значение темпера ры минус 25 градусов и подниматься записывается при помощи минимально возможного количества битов за некоторый период времени станция сделала 96 измерений каков информационный объем результатов наблюдений?

помогите какие знаете................ прошу помогите плиззз.......................

Решить задачи, составить программы:
1.Найти сумму цифр целого четырехзначного числа, и определить число,
цифры которого записаны в обратном порядку по отношению к исходному.
2.По введенному с клавиатуры аргументу вычислить значение функции.
3.Поменять местами значения двух переменных.
4. Написать программу ввода четырех чисел и вычисления их среднего арифметического.
5. Написать программу для вычисления дискриминанты квадратного уравнения.
6.Из железной полосы длиной L метров нужно изготовить обруч. На
соединение концов уходит D метров полосы. Написать программу вычисления
радиуса обруча.
7.Найти площадь конца, по введенным внешним и внутренним радиусам.
8.Найти расстояние между двумя точками по их координатам



Вы находитесь на странице вопроса "Pascal. Создать процедуру, которая может найти дискриминант квадр. уравнения по введённым коэффициентам.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.