Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста исправить программу, что бы она мне выдавала результат

5-9 класс

Условие: Яркости пикселей рисунка закодированы числами от 0 до 255 в виде матрицы. Преобразовать рисунок в чёрно-белый по следующему алгоритму:
1) вычислить среднюю яркость пикселей по всему рисунку
2) все пиксели, яркость которых меньше средней, сделать чёрными, (записать код 0), а остальные - белыми (код 255)

program lyly;
const n=4;
var a:array[1..n,1..n] of integer;
i,j,s:integer;
sr:real;
begin
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:= random (256);
write (a[i,j]:5);
end;
writeln
end;
begin
s:=0;
s:=s+a[i,j];
sr:=s/(n*n);
writeln;
writeln('Средняя яркость',sr);
end;
begin
writeln;
writeln ('Результат:');
if a[i,j] a[i,j]:=255;
end;
end.

1235852надежда 21 марта 2014 г., 7:49:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yaric2002n51
21 марта 2014 г., 8:43:57 (10 лет назад)

program lyly;

const
  n = 4;

var
  a: array[1..n, 1..n] of integer;
  i, j, s: integer;
  sr: real;

begin
  s := 0;
  Writeln('Исходная матрица');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := Random(256);
      Write(a[i, j]:5);
      s := s + a[i, j]
    end;
    Writeln
  end;
  sr := s / sqr(n);
  Writeln('Средняя яркость', sr);
  Writeln('Результирующая матрица');
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      if a[i, j] <= sr then a[i, j] := 0 else a[i, j] := 255;
      Write(a[i, j]:5)
    end;
    Writeln
  end
end.

Тестовое решение:

Исходная матрица
  108  247    9  175
   10   80  123   80
   75  165   82  128
  167  168    6   27
Средняя яркость103.125
Результирующая матрица
  255  255    0  255
    0    0  255    0
    0  255    0  255
  255  255    0    0


Ответить

Другие вопросы из категории

111. Даны полные имена файлов, хранящихся на диске D: D:\МЛЕКОПИТАЮЩИЕ\ЛАСТОНОГИЕ\тюлени.txt D:\МЛЕКОПИТАЮЩИЕ\Ластоногие\моржи .txt

D:\МЛЕКОПИТАЮЩИЕ\ХИЩНИКИ\МЕДВЕИ\панды. txt

D:\МЛЕКОПИТАЮЩИЕ\ХИЩНИКИ\МЕДВЕДИ\бурый медведь.txt

D:\МЛЕКОПИТАЮЩИЕ\ХИЩНИКИ\гепарды. txt

D:\МЛЕКОПИТАЮЩИЕ\ПАРНОКОПЫТНЫЕ\свиньи. txt

D:\МЛЕКОПИТАЮЩИЕ\ПАРНОКОПЫТНЫЕ\олени. txt

D:\МЛЕКОПИТАЮЩИЕ\ПАРНОКОПЫТНЫЕ\бегемоты. txt

D:\МЛЕКОПИТАЮЩИЕ\ГРЫЗУНЫ\бобры.txt

D:\МЛЕКОПИТАЮЩИЕ\сумчатые.txt

Изобразите соответствующую файловую структуру.

Объект моделирования – дом. Какие свойства этого объекта будут существенными для:а) архитектора, составляющего план дома;б) строителя, определяющего

перечень материалов, необходимых для строительства;в) художника, рисующего пейзаж, частью которого является дом?

помогите срочно надо!!!!)

в какой форме представлена информация в компьютере?
от чего зависит качество кодирования изображения растровым способом?
чему равен 1Мб?записать в Кб,байтах и битах?
как называется самая маленькая единица измерения информации?

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Всем информатикам сюда. Помогите пожалуйста,люди добрые...(

1)S=1+2+3...+10
for, while, repeat.

2)S=2+4+6+8...+20

for, while, repeat.
надо короче решить с помощью этих трех программ этот пример. что бы выходил этот ответ...помогите пожалуйста.

помогите пожалуйста! никак не могу с ноутбука зайти в вконтакт, но с телефона получается.появляется (ну это у всех) введите свой e-mail (или

телефон) и пароль .я ввожу, нажимаю войти, потом появляется картинка и говорят "Введите код с картинки" (эту функцию я отключила несколько лет назад!!! ) ,ну я думаю, хорошо, я введу, подумаешь три буковки. ВОТ! После этого проблема. мне пишут " Лена, мы зафиксировали попытку взлома Вашей страницы. Не беспокойтесь, она в безопасности. Чтобы обезопасить Вашу страницу от злоумышленников и в будущем, мы просим Вас подтвердить привязку к телефону и придумать новый сложный пароль. " Ладно я ввожу свой номер телефона, чтоб мне пришел код активации. Раньше мне приходило вот это"Для активации услуги подтвердите Ваше согласие с правилами, Ответь ДА стоимость отправки смс на номер 4012 - 203.19"!!! А сейчас уже если я наберу номер ничего абсолютно не происходит. Ага! Еще чего, не буду я на них целых 200 рублей тратить! Помогите пожалуйста мне решить эту проблему
И еще кое что, когда мой брат или подруга тоже попытались зайти в ВК у них всеё было тоже самое
С телефона пароль меняла, но ничего не изменилось

Помогите, пожалуйста ! У меня Windows XP Professional Servis Pack 3 , после того как я переустановил Windows на эту же самую систему , начал вылетать

Интернет.
Вот загрузился рабочий стол, подключаю Интернет , захожу в браузер можно сделать поисковые запросы и через некоторое время тема на рабочем столе меняется на старую , помните она как бы такая белая , вся квадратная , ну вот ,а потом обратно на мою выбранную тему .При этом в сетевых подключения показывает , что Интернет подключен , локальная сеть тоже , а в браузере не могу производить поиск пишет : " Нет подключения к Интернету " После перезагрузки компьютера можно снова .
Кто знает помогите , пожалуйста !



Вы находитесь на странице вопроса "Помогите пожалуйста исправить программу, что бы она мне выдавала результат", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.