Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Будьласка помогите. составить и запрограммировать алгоритм обработки одного массива на языке паскаль. задача выполнить произведение сумм позитивных и

10-11 класс

негативных элементов массива

IQPhoEnix 18 апр. 2014 г., 9:57:39 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89196254787s
18 апр. 2014 г., 12:38:52 (10 лет назад)

var
  x,n,p,i:integer;
  a:array[1..10]of integer;
begin
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  if a[i]>0 then p:=p+a[i] else n:=n+a[i];
  end;
x:=n*p;
writeln;
writeln('Ответ: ',x);
end.

Ответить

Другие вопросы из категории

До взрыва бомбы осталось 3 часа и 24 минуты, соответственно h=3 и m=24.

Напиши программу, которая сможет посчитать, сколько времени в минутах осталось до этого трагического события.

Помогите решить задание (задачу) на языке паскаль. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на

10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней? Разработать схему алгоритма для решения этой задачи.

Помогите сократить схему
Будь-ласка допоможіть розв*язати задачу:))

дуже дуже треба. Буду безмежно вдячна



В країні Тріантафіло проживає садівник-бізнесмен Іван
Петрович. Іван Петрович чудовий садівник, але в бізнесі він початківець.
Займаючись квітковим бізнесом, він не завжди досягав позитивних результатів:
були і збитки і прибутки. Допоможіть Івану Петровичу визначити фінансовий стан
його фірми за 2 роки роботи.

Вхідні дані:

Вхідний потік
містить два цілих числа x, y по модулю не більше 1030: прибутки або збитки за
перший і другий роки роботи фірми.

Читайте также

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Помогите, пожалуйста!!!

Составить блок-схему алгоритма решения задачи и программу на языке паскаль одним способом:

Σ сверху сигмы 40,снизу сигмы x=1 (x^2+(5/(x^2+8)))

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

Дана последовательность, содержащая от 2 до 30 слов, в каждом из от 1 до 8 символов строчных латинских букв между соседними словами-не менее одного

пробела, за последним словом-точка. Составить программу на языке Паскаль
1) Все слова, которые встречаются в последовательность по одному разу

Составить функцию определения факта нахождения в одномерной матрице хоть одного нуля, состоящей из целых чисел и количеством элементов k. применить данную

функцию для нахождения номеров строк, произвольной матрицы, не содержащей нулей. Составить на языке паскаль.



Вы находитесь на странице вопроса "Будьласка помогите. составить и запрограммировать алгоритм обработки одного массива на языке паскаль. задача выполнить произведение сумм позитивных и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.