Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Напишите пожалуйста программу с помощью Паскаля:Дана последовательность 5 9 13 17 21 25 29 33 37 41 45 49. Составьте программу для подсчета числа

10-11 класс

слагаемых сумма которых равна 324

Uuubars 12 авг. 2014 г., 10:26:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shpilkoya
12 авг. 2014 г., 12:49:28 (9 лет назад)

var sum, i, s: integer;  //обыявляем необходимые переменные

//sum - сумма, i - кол-во слогаемых, s - само слогаемое


begin  //начало
  sum := 0; i := 1; s := 5;  //первое слогаемое = 5
  while (sum < 324) do  //пока сумма меньше 324
  begin
    sum := sum + s;  //к сумме прибавляем слагаемое
    s := s + 4;  //увеличиваем слогаемое
    i := i + 1;   //увеличиваем кол-во слогаемых
  end;
  writeln ('Слогаемых: ');  // выводим кол-во слогаемых
  write (i);
end.  //конец

Ответить

Другие вопросы из категории

решение - объяснение - просто ответы есть (не пишите) Сколько существует различных пар натуральных чисел, таких что: 1. Оба

числа, записанные в пятеричной системе счисления, имеют ровно по три значащих разряда. 2. Сумма этих чисел, записанная в пятеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.

Что понимают под архитектурой CISC микропроцессора?

1) процессор со сложным набором команд и большим числом методов адресации памяти

2) процессор с внутренней организацией по классической архитектуре фон Неймана

3) классическая Манчестерская ЭВМ

4) процессор типа Pentium и выше

5) компьютер со сложным последовательным интерфейсом (complex interface serial computer)

Читайте также

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Даны 2 двузначных целых числа X и y.Найти D=MAX{x+y;y-x}+3,E=MIN{x^2+y^2;y^2+x*y}-4.если D<E,то к переменной D прибавить первую цифру числа

E,иначе из числа взять корень степени, равной второй цифре числа

если есть умеющте напишите,пожалуйста,программу в Паскале

Дана последовательность, содержащая от 2 до 30 слов, в каждом из от 1 до 8 символов строчных латинских букв между соседними словами-не менее одного

пробела, за последним словом-точка. Составить программу на языке Паскаль
1) Все слова, которые встречаются в последовательность по одному разу

дан целочисленный массив из n элементов A(n) в пределах от -20 до 20.Найти сумму тех чисел,которые кратны 5

напишите пожалуйста программу на паскале и блок схему!)



Вы находитесь на странице вопроса "Напишите пожалуйста программу с помощью Паскаля:Дана последовательность 5 9 13 17 21 25 29 33 37 41 45 49. Составьте программу для подсчета числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.