Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Pascal ABC

5-9 класс

Задача 1
составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .
Задача 2
составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Valiewa271198 02 окт. 2013 г., 8:09:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zhenyalp
02 окт. 2013 г., 9:58:35 (10 лет назад)

Первая программа ,если не нравится исправлю
Добавил вторую

+ 0 -
Настя6969
02 окт. 2013 г., 10:59:16 (10 лет назад)

1.
Program ZADACHA;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число не равное нулю a = ');
      readln(a);
      writeln;
      if a<0 then
      Write('Число a отрицательное, результат = ', a*a)
     
      else
      Write('Число a положительное, результат = ', a/2);


End.


2.
Program CHETNOST;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число a = ');
      readln(a);
      writeln;
      if (a mod 2) = 1 then
      Write('Да')
      else
      Write('Нет');

End.


Ответить

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Я работаю в прграмме Pascal ABC

Вот проверьте здесь гдето ошибка
program abc;
var a,b,c:integer;
begin;
write ('Длина равна=')
read(a);
write ('Ширина равна=')
read(b);
c:=a*b
write ('Площадь='c');
readln;
end.
Мне показало что в строке

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.



Вы находитесь на странице вопроса "Pascal ABC", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.