Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Сравнение

10-11 класс

чисел. Написать функцию, которая сравнивает два целых числа и возвращает
результат сравнения в виде кода символов одного из знаков <, >, =.

Dianusiksh 13 нояб. 2013 г., 7:23:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Deniskrotov36
13 нояб. 2013 г., 8:20:37 (10 лет назад)

#include <iostream.h>

char znak(int a,int b)
{
if(a>b)
return '>';
if(a<b)
return '<';
if(a=b)
return '=';
} ;

void main()
{
int a,b;
cin>>a>>b;
cout<<znak(a,b)<<"\n";
system("pause");
}

Ответить

Читайте также

В чем преимущество кода Бодо по сравнению с кодом Морзе?

В чем преимущество кода Морзе по сравнению с кодом Бодо?

РЕШИТЕ ПОЖАЛУЙСТА ТРИ ЗАДАЧИ 1)Вывести на экран число симметричное в веденному двухзначному число. 2)Вывести на экран

результат сравнения двух чисел.

3)Вести линейный массив и вычислить сумму всех элементов этого массива.

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.



Вы находитесь на странице вопроса "Сравнение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.