Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры последовательно вводятся длины сторон двух треугольников. Составить программу, которая производит сравнение площадей треугольников.

10-11 класс

( Решить с помощью процедуры. )

p.s. внизу моё решение!!!

Yura73 03 марта 2014 г., 11:30:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MrSabZero
03 марта 2014 г., 13:03:39 (10 лет назад)

vara1,b1,c1,p1,a2,b2,c2,p2,s1,s2:real;
Begin
read(a1,b1,c1);
p1:=(a1+b1+c1)/2;
read(a2,b2,c2);
p1:=(a2+b2+c2)/2;
s1:=sqrt(p1*(p1-a1)*(p1-b1)*(p1-c1));
s2:=sqrt(p2*(p2-a2)*(p2-b2)*(p2-c2));
if s1=s2 then
writeln('=') else
if s1>s2 then
writeln('>') else
writeln('<');
End.

Ответить

Другие вопросы из категории

Автомат получает на вход четырехзначное десятичное число, в котором все цифры четные. По этому числу строится новое число по следующим правилам.

1. Складываются 1я и 2я, а также 3я и 4я цифры.
2. Полученные два числа записываются друг за другом в порядке убывания(без разделителей).

Определите, какое из перечисленных ниже чисел может быть результатом работы автомата.
1) 68
2) 87
3) 816
4) 186
Объясните почему) Заранее спасибо!

Читайте также

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)



Вы находитесь на странице вопроса "С клавиатуры последовательно вводятся длины сторон двух треугольников. Составить программу, которая производит сравнение площадей треугольников.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.