Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив А(N). Определить количество нечетных и отрицательных элементов массива. Изменить знак у элементов. Вывести исходный и преобразованный массив и

10-11 класс

количество элементов.

DoTman 18 дек. 2016 г., 6:17:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
блестящая
18 дек. 2016 г., 6:50:04 (7 лет назад)

uses  SysUtils,Windows;
var a:array of Integer;    i,n,s,o:Integer;
begin 
o:=0; 
 s:=0; 
SetConsoleOutputCP(1251); 
Randomize; 
 write('Введите "N": ');
  readln(n); 
 SetLength(a,n);
  for i:=0 to Length(a) do   
begin 
    a[i]:=Random(10)-5;
     write(a[i]:3); 
  end;
   Writeln;
    Writeln; 
for i:=0 to Length(a) do 
  begin
     if a[i] mod 2=1 then 
     Inc(s);
     if a[i]<0 then
      Inc(o);
     a[i]:=a[i]*(-1);
   end; 
 Writeln('Кол-во отрицательных элементов: ',o); 
  Writeln('Кол-во нечетных элементов: ',s);
    Writeln;   
for i:=0 to Length(a) do 
    write(a[i]:3); 
 readln;
end.

Ответить

Другие вопросы из категории

1. Перед вами пример кода HTML.

Необходимо подсчитать количество ошибок сделанных в записи

тэгов.

Читайте также

Задача первая.

Дан массив O ( K ). Заменить все положительные числа квадратом числа,а отрицательные модулем.
Задача вторая.
Дан массив R ( 6 ) .Найти сумму и произведение всех элементов массивов.

Через Qbasic

ОТ CLS ДО ЕND

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1.Даны два массива: А(5) и В(5). Сформируйте из них массив С,предварительно определив его длину,включая попеременно из массива А положительные

элементы, а из массива В -нечетные по значению.Выведите на экран массивы А,В,С.

2.Информация о площадях и средней урожайности хранится в массиве,где каждый элемент с четным индексом - засеянная площадь, а с нечетным - урожайность.Определите и выведите на экран кол-во собранной пшеницы и среднюю урожайность.

Помогите пожалуйста!



Вы находитесь на странице вопроса "Дан массив А(N). Определить количество нечетных и отрицательных элементов массива. Изменить знак у элементов. Вывести исходный и преобразованный массив и", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.