Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Массив паскаль помогите пожалуйста: заполнить массив 20-ю целыми числами из диапозона -50;50. найти номер последнего четного элемента и количество

10-11 класс

отрицательных до последнего четного

Feel678 25 марта 2017 г., 22:29:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aniotkalove
25 марта 2017 г., 23:55:01 (7 лет назад)

program noname;
uses crt;
var
a:array[1..100] of integer;
i,n,k:byte;
begin
clrscr;
for i:=1 to 20 do begin
randomize;
a[i]:=random(100)-50;;
write(a[i],' ');
if (a[i] mod 2=0) and (a[i]<>0) then k:=i;
end;
n:=0;
for i:=1 to k do
if a[i]<0 then n:=n+1;
writeln;
writeln(k,'-номер последнего четного');
writeln(n,'-число отрицательных элементов до ', a[k])
end. 

Ответить

Другие вопросы из категории

C++

Расположить строки заданной матрицы по возрастанию количества одинаковых элементов в каждой строке.

На ферме установлены следующие расценки:

бык стоит 25 000р.,

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20].

Найти номер первого отрицательного элемента, делящегося на 5 с остатком 2.напишите пожалуйста программу в лазарусе



Вы находитесь на странице вопроса "Массив паскаль помогите пожалуйста: заполнить массив 20-ю целыми числами из диапозона -50;50. найти номер последнего четного элемента и количество", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.