Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Здравствуйте! Очень надеюсь на вашу помощь! Написать программу на языке Pasсal, меняющую все слова "red" на "black", "tree" на "palms" из

5-9 класс

текста, указанного в файле in.txt и сохраняющую результат в файл out.txt. Все остальные слова, пробелы, запятые, точки и т.п должны остаться без изменений.

Вот сам текст:

A red black tree is a binary search tree where each node has a color attribute the value of which is either red or black In addition to the ordinary requirements imposed on binary search trees the following requirements apply to red black trees. A node is either red or black The root is black This rule is sometimes omitted from other definitions. Since the root can always be changed from red to black but not necessarily vice versa this rule has little effect on analysis. All leaves are the same color as the root Both children of every red node are black. Every simple path from a given node to any of its descendant leaves contains the same number of black, black, black, very "black" nodes.

мирея 13 июня 2014 г., 17:11:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dianabelikova11
13 июня 2014 г., 19:38:59 (9 лет назад)

var myInFile, myOutFile: text;
   ind: integer;
   currentString: string;
begin
   assign(myInFile, 'in.txt');
   reset(myInFile);
   assign(myOutFile, 'out.txt');
   rewrite(myOutFile);
   while (not EOF(myInFile)) do
   begin
      currentString := readln(myInFile);
      while (pos('red', currentString) > 0) do
      begin
         ind := pos(currentString, 'red');
         delete(currentString, ind, length('red'));
         insert('black', currentString, ind);
      end;
      while (pos('tree', currentString) > 0) do
      begin
         ind := pos(currentString, 'tree');
         delete(currentString, ind, length('tree'));
         insert('palms', currentString, ind);
      end;
   end;
   close(myInFile);
   close(myOutFile);
end.

Ответить

Другие вопросы из категории

Помогите кто нибудь умоляю;((
Составить програму на паскале.

Дано натуральное число,приписать к нему такое же число!

Читайте также

Очень надо. В ИКТ полный ноль. Нужен паскаль и блок схема. Вот сама задача:Каждая бактерия делится на две в течении 1 минуты. В начальный

момент имеется одна бактерия. Составьте блок-схему алгоритма вычисления количества бактерий через 10 минут. Исполните алгоритм, фиксируя каждый его шаг в таблице значений переменных.
Заранее спасибо, надеюсь на вашу помощь)

напишите программу в Паскаль чтобы нарисован был светофор)) небольшой, разрисован нужными цветами( жёлтый, зелёный, красный) и сам светофор

серый..Помогите пожалуйста...ставлю спасибо))) надеюсь на вашу помощь)))( программу не большую)

напишите программу в Паскаль чтобы нарисован был светофор)) небольшой, разрисован нужными цветами( жёлтый, зелёный, красный) и сам светофор

серый..Помогите пожалуйста...ставлю спасибо))) надеюсь на вашу помощь)))( программу не большую)



Вы находитесь на странице вопроса "Здравствуйте! Очень надеюсь на вашу помощь! Написать программу на языке Pasсal, меняющую все слова "red" на "black", "tree" на "palms" из", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.