Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Cоставить модуль,который содержит подпрограммы,для заполнения одномерного массива целых чисел,вычисления суммы элемента данного массива. Написать

5-9 класс

программу с использованием этого модуля.

FanAriDje 07 дек. 2014 г., 14:27:30 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dimon110300
07 дек. 2014 г., 16:37:32 (9 лет назад)

const
  n = 50;

type
  V = array[1..n] of integer;

procedure Init(var a: V);

var
  i: integer;

begin
  Randomize;
  for i := 1 to n do
    a[i] := Random(100) - 50
end;

function Sum(a: V): integer;

var
  i, s: integer;

begin
  s := 0;
  for i := 1 to n do
    s := s + a[i];
  Sum := s
end;

var
  x: V;
  i, c: integer;

begin
  Init(x);
  c := Sum(x);
  writeln('Сформированный массив');
  for i := 1 to n do
    Write(x[i]:4);
  Writeln;
  Writeln('Сумма членов: ', c)
end.

Тестовое решение:
Сформированный массив
 -14   9 -46  30  41  38 -43   7  24 -16  -2  47 -39  -5 -27  43  13 -29 -21  28  28  13  27  26  49   5 -16 -14 -43 -32  -9  22 -48  21  29  19   9 -27 -44 -49  -1  31 -30  47 -35 -48 -10  46   9  -5
Сумма членов: 8


+ 0 -
Marirub
07 дек. 2014 г., 17:59:52 (9 лет назад)

Комментарий удален

+ 0 -
Vatka100500
07 дек. 2014 г., 19:09:18 (9 лет назад)

человек с клавы вводит элементы массива(короче в данном случае случайные) и в модуле должно быть 2 подпрограммы

+ 0 -
AngelAnimated
07 дек. 2014 г., 21:18:13 (9 лет назад)

Комментарий удален

+ 0 -
Nadya2112
07 дек. 2014 г., 23:14:56 (9 лет назад)

ждет ввод... да функции

+ 0 -
Dinylik
08 дек. 2014 г., 0:33:31 (9 лет назад)

Комментарий удален

Ответить

Читайте также

Школьный уровень 1.Найти все элементы массива b(n),большие или равные 0.На экран вывести номер элементо

в,их значения и количество.

2.В одномерном массиве целых чисел,содержащем 20 элементов,удалить k-ый элемент массива.Массив заполняется случайным образом числами от 0 до 50.

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Для упорядочивания по возрастанию массива целых чисел из 20 элементов (номера элементов начинаются с 0) начинающий программист написал следующий фрагмент

программы:
For i:=1 to 100 do
For j:=1 to 18 do
If a [j-1] > a [j+1] then
Begin
T := a [j-1]; a [j-1] := a [j+1]; a [j+1] := t
End;
Чему станет равен элемент массива с номером 4, если в начале работы фрагмента в массиве находились числа от 20 до 1 в порядке убывания?

Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски

расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.
Входные данные:
Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D <= 1000).

Выходные данные:
Вывести единственное число.

Пример входного файла (input.txt):
10 1 1 2 3
Пример выходного файла (output.txt):
14

Язык Borland C++ никаких паскалей

Написать программу,позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива.Длина массива N
задается пользователем как константное выражение.Исходные данные задать вручную или с помощью генератора случайных чисел,учитывая формат элементов массива А.Тип результата определяется из контекста.
-Вычислить количество отрицательных элементов массива;
-сумму модулей элементов массива,расположенных после максимального элемента



Вы находитесь на странице вопроса "Cоставить модуль,который содержит подпрограммы,для заполнения одномерного массива целых чисел,вычисления суммы элемента данного массива. Написать", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.