Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В базе данных хранятся записи, содержащие информацию о датах. Каждая запись содержит три поля: год (число от 1 до 2100), номер месяца (число от 1 до

5-9 класс

12) и номер дня в месяце (число от 1 до 31). Каждое поле записывается отдельно от других полей с помощью минимально возможного числа бит. Определите мини­мальное количество бит, необходимых для кодирования одной записи.

Jbu 20 нояб. 2015 г., 3:06:51 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Moshielena
20 нояб. 2015 г., 5:51:15 (8 лет назад)

type
  Data = record
    Year: 1..2100;
    Month: 1..12;
    Day: 1..31;
  end;
begin
  writeln(sizeof(Data) * 8, ' бит'); {sizeof(Data) показывает размер типа Data в байтах

                                                 умножение производится для перевода байтов в                                      биты}

end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста! Срочно
Помогите пожалуйста! нужно решить задачу

Пусть небольшая книжка содержит 150 страниц, на каждой странице 60 символов, всего 40 строк. Найдите весь обьём информации

program lol;

var x,a,b,d,y,h1,h2,h3,h4,h5,h6,h7,h8,h9,h10,h11,h12,h13,h14,h15,h16:real;

Читайте также

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))

Помогите написать программу которая по данному натуральному числу от 1 до 2 (номеру месяца) выдает все приходящихся на этот месяц праздничные

дни(например, если введено число 1, то; 1 января - новый год , 7 января - Рождество).



Вы находитесь на странице вопроса "В базе данных хранятся записи, содержащие информацию о датах. Каждая запись содержит три поля: год (число от 1 до 2100), номер месяца (число от 1 до", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.