Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Как сделать так что бы программа выводила наименьшее число? var

5-9 класс

a, b, c: integer;
d: array [1..10] of integer;
begin
for b := 1 to 10 do
begin
write('Bведите число ', b, ' ');
d[b] := random(100) + 100;
writeln(d[b]:4);
end;
b := d[1];
c := 1;
for b := 2 to 10 do
begin
if d[b]>a then
begin
a := d[b];
c := b;
end;
end;
write('Самое большое число под номером ', c, ' это число ', a);
end.

Ildarfazylov7 07 июля 2013 г., 0:55:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kuznezova037
07 июля 2013 г., 2:27:19 (10 лет назад)

вар, б, в: целое;г: массив [1 .. 10] из целого;начинатьдля Ъ: = 1 до 10 сделатьначинатьнаписать ('Bведите число', Ь, '');D [B]: = случайных (100) + 100;WriteLn (г [б]: 4);конец;б: = D [1];с: = 1;для Ъ: = 2 до 10 сделатьначинатьесли г [б]> тоначинать: = D [б];с: = б;конец;закончить;написать ('Самое большое число под номером', с, 'это число',);конец.

Ответить

Другие вопросы из категории

номер 82

ПОМОГИТЕ
♠♠♥♥♥♥♥♥♥♥♥♥♥♥♥♥♥♥♥

Помогите с программой, плиз)

Составте программу, которая заполняет массив а[1..8] случайными целыми числами от 1 до 10 и выводит на экран количество элементов с чётными значениями и сумму элементов массива с нечётными значениями

4. Угадайте правило шифрования и

расшифруйте слова:

Читайте также

Как сделать так, чтоб текс программы открытый в блокноте (который на русском) был в нормальном шрифте , а не была билибирда? Типо такого:

outtextxy(15,180,'„ўЁ¦Ґ­ЁҐ ⥫ ,Ўа®иҐ­­®Ј® Ј®аЁ§®­в «м­® б ­ з «м- ');outtextxy(110,210,'­®© бЄ®а®бвмо Ї® гЈ«®¬ Є Ј®аЁ§®­вг');

Прошу написать 2 рабочих программы Pascal Так что бы скопипастть в программу и не возиться, заранее благодарю 1)

Составить программу решения

линейного уравнения: ах + в = 0,

при (а <> 0)

2)

Посчитать, сколько молекул воздуха находится в данной комнате.

по поводу этой задачи от себя могу добавить (

молярная масса воздуха принимается равной 29 г/моль.
зная объем комнаты (параллелепипед высота*ширина*длина) находите объем в литрах. объем/22,4=количество в молях. полученный результат умножается на число авогадро и ответ готов (без учета давления и температуры)

надеюсь это поможет вам в составление программы и тем самым оказании услуги многим-многим школьникам, попавим в неловкое положение, в последние дни четверти.

Paskal abcТут задача, в которой нужноPaskal abc

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);


readln(x);


until y=x


writeln(‘Поздравляем,
вы ввели пароль верно’);


end.

Paskal abc

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);

Здравствуйте! Мы сделали кнопки в PascalABC.Net. Как сделать так, чтобы когда на них нажимаешь, то выводился на экран текст. Заранее спасибо.

Вот код программы:

uses GraphABC, ABCObjects,ABCButtons;

begin
MaximizeWindow;
var btword := new ButtonABC(50,125,500,100,'Играть',clWhite);
var btword1 := new ButtonABC(50,325,500,100,'Настройки',clWhite);
var btword2 := new ButtonABC(50,525,500,100,'Правила',clWhite);
var btword3 := new ButtonABC(50,725,500,100,'Выход',clWhite);
end.



Вы находитесь на странице вопроса "Как сделать так что бы программа выводила наименьшее число? var", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.