Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Paskal abcТут задача, в которой нужноPaskal abc

5-9 класс

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);


readln(x);


until y=x


writeln(‘Поздравляем,
вы ввели пароль верно’);


end.

Shramkova86 19 дек. 2013 г., 15:24:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zayabrr
19 дек. 2013 г., 17:43:19 (10 лет назад)

можно сделать с помощью цикла:
var
s1:string;
s: array [1..3] of string;
i,j:longint;
begin
readln(s1); {input password}
j:=0;
for i:=1 to 3 do
begin
readln(s[i]);
if s[i]=s1 then    
  begin        
    writeln('Пароль введен правильно'); exit;  
  end        
              else            
   begin           
      inc(j);           
      if j=3 then writeln('Вы ввели не верный пароль, попытки исчерпаны');                   end;
end;
end.
P.S. копировал со своего паскаля, так что красоту сам наведешь (и у меня программа работает, если будет такой вопрос)

Ответить

Другие вопросы из категории

Решите задачи.

1-ая.
Ученик собирался на вечер, когда погас свет в комнате, где в ящике шкафа лежали его коричневые и синие носки. Какое наименьшее число носков он должен взять из ящика, чтобы обеспечить себя парой одного цвета?

Срочно,кто знает javascript ?

Написать функцию которая подсчитывает факториал числа,заданого параметра
а) Вспомнить что факториал числа n равен 1*2*3...*n,факториал 0 равен 1,
факториала числа 0 не существует
б) написать функцию принемущую в качестве параметра число n
в)вернуть в функции факториал числа N

Помогите пожалуйста! напишите программу паскаль. вроде циклы

Дано натуральное число N. Определить, является ли оно совершенным. Совершенное число N равно сумме его делителей, не превосходящих само N.

Читайте также

Paskal abc

Тут задача, в которой нужно ввести верно пароль, ну дак вот нужно составить похожую программу, но так что-бы было 3 попытки ввода пароля, ну и после этих попыток будет например "Вы ввели не верный пароль, попытки исчерпаны"
можно сделать через string
------------------------
program
test1;


var
x,y:integer;


begin


y:=555;


repeat


writeln(‘введите
пароль’);

решите пожалуйста задачи на языке pascal abc net.

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.




Вы находитесь на странице вопроса "Paskal abcТут задача, в которой нужноPaskal abc", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.