Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

решите пожалуйста задачи на языке pascal abc net.

5-9 класс

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.

1982inna1982 04 нояб. 2013 г., 18:33:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Stefzes
04 нояб. 2013 г., 21:28:24 (10 лет назад)

1)program qq;
var a:integer;
begin
readln (a);
if a > 0 then
a:= a + 1;
if a < 0 then
a:= a - 2;
if a = 0 then
a:= 10;
writeln (a);
end.
2)

+ 0 -
Ангелина1028
04 нояб. 2013 г., 22:17:37 (10 лет назад)

f3 uses crt; var a:integer; begin readln(a); if (a>0) then begin a:=a+1; end; if (a<0) then begin a:=a-2; end; if (a=0) then begin a:=10; end; end.

Ответить

Другие вопросы из категории

Племя Пульти пользуется 32 - символьным алфавитом. Свод основных законов племени хранится на 514 глиняных табличках, на каждую из которых нанесено

ровно 256 символов. Какое кол - во информации содержится на каждом носителе? Какое кол - во информации заключено во всем своде законов?

Составьте программу, которая формирует массив из 40 случайных целых чисел от 2 до 20 и вычисляет: а) среднее арифметическое нечётных чисел

>б) сумму чисел, не превышающих 10

в) сумму чисел, кратных трём

плииз, каждую задачу отдельно.. если не уверенны не пишите.. срочно!!

5-9 класс информатика ответов нет
Два текста содержат одинаковое количество символов. Первый текст составлен в алфавите мощностью 16 символов, а второй текст – в алфавите из 256 символов.

Во сколько раз количество информации во втором тексте больше, чем в первом?

Помогите с заданием,пожалуйста.

В таблице (она во вложениях)приведена стоимость перевозок между соседними железнодорожными станциями.
Постройте схему (взвешеный граф) ,соответствующую таблице.
Надо нарисовать схему.Заранее спасибо.

Читайте также

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Ребят задача на языке Pascal...

Дано целое число, если оно двузначное, то умножить на 2, в противном случае вычесть 10.

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений



Вы находитесь на странице вопроса "решите пожалуйста задачи на языке pascal abc net.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.