Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите пожалуйста эти задачи на языке Pascal

5-9 класс

Lancik19 25 авг. 2013 г., 10:38:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юлz163
25 авг. 2013 г., 13:08:31 (10 лет назад)

1.
program first;
var a:array[1..6] of real;
     summ:real;
     i:integer;
begin
summ:=0;
for i:=1 to 6 do read(a[i]);
for i:=1 to 6 do summ:=summ+a[i];
writeln(summ);
end.

2.
program second;
var a: array[1..10] of integer;
     i, pr:integer;
begin
proiz:=1;
for i:=1 to 10 do read(a[i]);
for i:=1 to 10 do if (i mod 2<>0) then pr:=pr*a[i];
writeln(pr);
end.

3.
program third;
var a:array[1..10] of integer;
     i, count, summ:integer;
     srznach:real;
begin
summ:=0;
count:=0;
for i:=1 to 10 do read(a[i]);
for i:= 1 to 10 do if (a[i]>=0) then 
 begin
 count:=count+1;
 summ:=summ+a[i];
 end;
srznach:=summ/count;
writeln(summ);
end.

Ответить

Другие вопросы из категории

Матрица 7х6

1.Произв в столбце 1
2.Координата(номер столбца) ячейки в строке 5 со значением >0

Вариант 1

1.3 Мбайт = ......Кбайт

Читайте также

решите пожалуйста задачи на языке pascal abc net.

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.

Ребят задача на языке Pascal...

Дано целое число, если оно двузначное, то умножить на 2, в противном случае вычесть 10.

Очень надо!! пожалуйста)Составить программу на языке Pascal, которая позволяет ввести с клавиатуры целое трехзначное число, проверяет, симметрично ли оно,

и печатает сообщение на экране. (Трёхзначное число симметрично, если крайние цифры числа одинаковые)

ПОМОГИТЕ ПОЖАЛУЙСТА С ДВУМЯ ЗАДАЧАМИ НА ЯЗЫКЕ PASCAL: 1)даны 2 числа, заменить второе число нулем, если оно не меньше первого и оставить его

прежним,если это не так. 2)Даны 3 числа, возвести в квадрат те из них, значения которых не отрицательны, а отрицательные оставить без изменений



Вы находитесь на странице вопроса "Решите пожалуйста эти задачи на языке Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.