Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

вычислить число пи через разложение в ряд

10-11 класс

\pi/4 = 1-1/3+1/5-1/7+... = \sum_{k=1}^{\infty}{(-1)^{k+1}*\frac{1}{2*k-1}

взяв 500 слагаемых

Eriminyuk 03 авг. 2013 г., 11:26:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мария1242
03 авг. 2013 г., 13:15:23 (10 лет назад)

Если power изучали, то можно так:
var
   k:integer;
   p:real;
begin
for k:=1 to 500 do
  p:=p+power(-1,k+1)/(2*k-1);
writeln('Pi/4 = ',p)
end.
 Если не изучали, пиши, сделаю по-другому.

Версия для Турбо:

program rd;

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.



Вы находитесь на странице вопроса "вычислить число пи через разложение в ряд", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.