Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача на паскале

5-9 класс

Вычислить разность между наибольшим и наименьшим элементами заданного массива из N элементов.

(Пожалуйста, напишите решение полностью)

Лина0810 28 марта 2017 г., 15:46:05 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivetka
28 марта 2017 г., 16:28:43 (7 лет назад)

var A: array [1..100] of integer;

i,max,min,s: integer;

begin

randomize;

for i := 1 to 100 do begin

A[i] := random(100);

end;

max := 1;

for i := 2 to 100 do begin

if (A[i] > A[max]) then max := i;

end;

min := 1;

for i := 2 to 100 do begin

if (A[i] < A[min]) then min := i;

end;

s := A[max] - A[min];

writeln(s);

end.

Ответить

Другие вопросы из категории

Образы огня в живописи
16-чная система счисления

Какие числа идут далее
A B C D E F 10 11 ..
Достройте пожалуйста до 30

В некоторой стране автомобильный номер длиной 14 символов составляют из

заглавных букв (задействовано 26 различных букв) и десятичных цифр в любом порядке.
Каждый такой номер в компьютерной программе записывается минимально возможным и
одинаковым целым количеством байт (при этом используют посимвольное кодирование и
все символы кодируются одинаковым и минимально возможным количеством бит).
Определите объем памяти, отводимый этой программой для записи 50 номеров.

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

1)Как можно описать на Паскале 1)Как можно описать на Паскале массив,в котором будет храниться значения численности населения Москвы к концу

каждого года XX века?
2)Вы приобрели котёнка.Каждый вечер вы определяете его вес с помощью весов.Как можно описать на Паскале массив,в котором будет храниться значения веса котёнка в течение месяца (например,мая)?

Люди очень срочно решите пожалуйста задачу на Паскале:

их 4 штуки!
1.дан массив тз N элементов. Есть ли в нем чётные элементы, которые кратны заданному числу K.
2. Дан массив из Nэлементов. Посчитать, сколько элементов массива равных минемальному.
3. Сформировать массив из Nэлементов: 10 12 16 22 30 40.
4. Дан массив из Nэлементов. Перемножить минемальные элементы на 2.
Heeelp!



Вы находитесь на странице вопроса "Задача на паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.