Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

даны 2 числа. написать процедуру или функцию возведения числа в степень. возвести наибольшее число в степень наименьшего

10-11 класс

Natalianabel 24 марта 2017 г., 0:04:07 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
амишка2001
24 марта 2017 г., 0:36:46 (7 лет назад)

Паскаль.

 

uses crt;
var a,n:integer;
begin
clrscr;
write('Введите число: '); read(a);
write('Введите еще одно число: '); read(n);
if a>n then write(a,'^',n,'=',exp(ln(a)*n))
else write(n,'^',a,'=',exp(ln(n)*a));
end.

 

{P.s. Рабочая, если хотя бы одно из чисел положительное}

Ответить

Другие вопросы из категории

Помогите пожалуйста написать программу в КуМире.

Написать программу с клавиатуры вводится пять чисел.Нужно определить сколько четных и сколько не четных.

ТЕПЕРЬ БОМ ЗАГАДЫВАЕТ ДВА ЧИСЛА,А БИМ ПРОСИТ ВЫПОЛНИТЬ С ЭТИМ ЧИСЛАМИ ДЕЙСТВИЯ ПО АЛГОРИТМУ И СООБЩИТЬ РЕЗУЛЬТАТ.ПО РЕЗУЛЬТАТАМ БИМ ВСЕГДА ОТГАДЫВАЕТ

ВТОРОЕ ЧИСЛО.ЧТОБЫ УЗНАТЬ СЕКРЕТ ЭТОГО ФОКУСА,ВЫПОЛНИ АЛГОРИТМ ДЛЯ ТРЕХ РАЗНЫХ ПАР ЧИСЕЛ.ЗАПИСЫВАЙ ,ЧТО ПОЛУЧАЕТСЯ ПОСЛЕ КАЖДОГО ДЕЙСТВИЯ.1.НАЧАЛО 2.ЗАГАДАЙ ЛЮБОЕ ЧИСЛО А И ЛЮБОЕ ЧЕТНОЕ ЧИСЛО Б 3.УМНОЖЬ ЧИСЛО А НА 2 4.К РЕЗУЛЬТАТУ ПРИБАВЬ ЧИСЛО Б 5.РАЗДЕЛИ СУММУ НА 2 6. ВЫЧТИ ЧИСЛО А 7. СООБЩИ РЕЗУЛЬТАТ 8 КОНЕЦ ЧТО ПОЛУЧ 31,8

Читайте также

Помогииииите пооожааалуйста. От этой задачи зависит оценка в четверти!!!!

Паскаль. Задано 4 числа. Первое поменять местами со 2, а 3 с 4. Используя процедуру или функцию.
Задано: 1 2 3 4
Должно получиться: 2 1 4 3

СРОЧНО!!!!!!!!!!!!!!!!!!Написать программу в паскале + составить блок-схемы:

4)Если целое M делится на целое число NБ то на экран выводится частное от деления,в противном случае выводится сообщение"M на N нацело не делится".
8)Одинаковы ли цифры данного двухзначного числа.
9)является ли сумма цифр двухзначного числа четной.
12)кратна ли числу A сумма цифр двухзначного числа.
14)какая из цифр трехзначного числа больше: первая или вторая.
16) все ли цифры трехзначного числа одинаковые.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Помогите написать процедуру и функцию преобразования положительного десятичного числа, в восьмеричное. В основной программе ввести массив из 8 элементов

при помощи случайных чисел, и для каждого элемента массива вывести его восьмеричное представление

1. Определить, сколько байт содержится в 0.125 Гбайтах. Результат представить как возведенное в степень число 2.

2. Определить, сколько Гбайт содержится в 512 байтах. Результат представить как возведенное в степень число 2.



Вы находитесь на странице вопроса "даны 2 числа. написать процедуру или функцию возведения числа в степень. возвести наибольшее число в степень наименьшего", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.