Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите, пожалуйста, написать код на Паскале!

5-9 класс

Даны номерные знаки автомашин двух таксопарков
N1..N10
NN1..NN15
и расходы топлива каждой из автомашин за месяц
R1..R10
RR1..RR15
напечатать номерные знаки автомашин первого и второго таксопарков с максимальными и минимальными расходами топлива.

Veronikazserova 24 авг. 2015 г., 15:24:24 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yulenkasemenova
24 авг. 2015 г., 17:21:20 (8 лет назад)

var N1:array[1..10] of integer;
    N2:array[1..15] of integer;
    R1:array[1..10] of integer;
    R2:array[1..15] of integer;
    min1, min2, max1, max2, i:integer;
    R1min, R2min, R1max, R2max:integer;
begin
min1:=500;
min2:=500;
max1:=0;
max2:=0;
randomize;
for i:=1 to 10 do
N1[i]:=random(900)+100;
for i:=1 to 15 do
N2[i]:=random(900)+100;
for i:=1 to 10 do
R1[i]:=random(500);
for i:=1 to 15 do
R2[i]:=random(500);
for i:=1 to 10 do
 if R1[i]<min1 then
  begin
  min1:=R1[i];
  R1min:=i;
  end else
   begin
   if R1[i]>max1 then
    begin
    max1:=R1[i];
    R1max:=i;
    end;
   end;
for i:=1 to 15 do
 if R2[i]<min2 then
  begin
  min2:=R2[i];
  R2min:=i;
  end else
   begin
   if R2[i]>max2 then
    begin
    max2:=R2[i];
    R2max:=i;
    end;
   end;
writeln('v 1 taxoparke min ', N1[R1min]);
writeln('vo 2 taxoparke min ', N2[R2min]);
writeln('v 1 taxoparke max ', N1[R1max]);
writeln('vo 2 taxoparke max ', N2[R2max]);
write('N1 ');
for i:=1 to 10 do
write(N1[i], ' ');
writeln;
write('R1 ');
for i:=1 to 10 do
write(R1[i]:3, ' ');
writeln;
write('N2 ');
for i:=1 to 15 do
write(N2[i], ' ');
writeln;
write('R1 ');
for i:=1 to 15 do
write(N1[i]:3, ' ');
writeln;
end.

Ответить

Другие вопросы из категории

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите, пожалуйста, написать программу на Паскале.

Дана строка. Верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?

Помогите, пожалуйста, срочно написать код на паскале! Все голову сломала:(

Даны массивы Н1..Н5 шифры предприятий 1ой группы
НН1..НН8 шифры предприятий 2ой группы
N1..N5 наименование продукций предприятий 2ой группы
NN1..NN8наименование продукций предприятий 2о1 группы
Вывести списки предприятий выпускающих одинаковую продукцию

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!



Вы находитесь на странице вопроса "Помогите, пожалуйста, написать код на Паскале!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.