Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите срочно!!!цикл while. Для n-чисел, <=100 найти произведение тех чисел которые кратны 3.

10-11 класс

СимаСимона 31 июля 2013 г., 18:09:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aleksamova
31 июля 2013 г., 20:56:52 (10 лет назад)

var a,n,s: integer;

begin

  s:=1;

  n:=1;

  while n<=100 do begin

    readln(a);

    if a mod 3 =0 then s:=s*a;

    n:=n+1;

                          end;

  writeln(s);

end.

  Вроде так

Если что не так, исправлю

+ 0 -
Saraakolganatovna
31 июля 2013 г., 22:39:40 (10 лет назад)

#include <cstdlib>
#include <iostream>

using namespace std;                        //ни чего особо не значит, чисто                                                                   //синтаксис,на алгоритм не влияет


int main()                      
{

 int n=0;

 int a=1;

 while(n<=100)

 {

  if(n%3==0 && n!=0)

  {

   a*=n;                                       //a=a*n

  }

  n++;                                         //n=n+1

 }

 cout<<"Произведение равно "<<a<<endl;
 system("PAUSE");
 return 0;
}

 

 

 

 

 

(Код написан на С++.)

 

-------------------------------------------------------------------------------------------------

 

#include <cstdlib>
#include <iostream>

using namespace std;


int main()
{

 int n=0;

 int a=1;

 while(n<=100)

 {

  if(n!=0)                                         //если умножить на 0 то а в итоге будет равно

   a*=n;                                           //0 (0 делиться на 3)

  n+=3;                                           //n=n+3   (каждое третье делиться на 3,                                                         //увеличиваем сразу на 3)

 }

 cout<<"Произведение равно "<<a<<endl;
 system("PAUSE");
 return 0;
}

 

 

 

 

 

(Код написан на С++.)

 

 

Ответить

Другие вопросы из категории

Записать в десятичной системе счисления числа

110001111(2)
101(8)
А9(16)

Написать программу в C++

Дан одномерный массив x из n элементов.
Найти порядковый номер первого по счёту
положительного элемента с чётным порядковым номером. Все отрицательные элементы
после него переписать в массив y.

Дан массив А, состоящий из 6 элементов. Поменять

местами максимальный и отрицательный элементы. Вывести новый массив

Читайте также

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.

ПОМОГИТЕ СРОЧНО!!!

в массиве a1,a2...a50 найти произведение чисел меньших или равных 2

Помогите пожалуйста решить задачу в Pascal ( и если можно Блок схему ) . Найти произведение элементов массива, кратных 3 и 9. Размерность массива -10.

Заполнение массива осуществить случайными числами от 5 до 500. Срочном пожалуйста ребят !!

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "помогите срочно!!!цикл while. Для n-чисел, &lt;=100 найти произведение тех чисел которые кратны 3.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.