Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дана строка. Найти в ней те слова, которые начинаются и оканчиваются одной и той же буквой

10-11 класс

VladKovtunenko 23 июля 2014 г., 21:29:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nenorma
23 июля 2014 г., 23:22:06 (9 лет назад)

var s:string;

start,finish,i:integer;

Begin

  {read(s);}
  s:='I aha, go home i';

  start:=1;

  for i := 2 to length(s)+1 do begin

    if (s[i] in [' ',',','.']) or (i=length(s)) then begin

      finish:=i-1;

      if s[start]=s[finish] then writeln(copy(s,start, finish-start+1));

      start:=i+1;

    end;

  end;

End.

Ответить

Другие вопросы из категории

Помогите пожалуйста)

Нужно составить в паскале программу для проверки пароля, совсем не понимаю паскаль, для меня это темный лес!)

Данные при передаче по сети разбиваются на пакеты

размером 2 килобита. Определите минимальное количество пакетов, которое
потребуется сформировать при передаче файла размером 18150 байтов.

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

решить задачу в паскале. С клавиатуры вводится слово. Составить программу, которая запрашивает ввести следующее слово, которое начинается с последней

буквы предыдущего и осуществляет проверку. Результатом программы является сообщение "Правильно" или "Неправильно"

1.Дана строка: ПЛУВЕТ ЛАДКА. Напишите действия,которые необходимо сделать со строкой,чтобы получилось:ПЛЫВЕТ ЛОДКА

2.Дано слово ДЕРЕВО.Напишите действие,которое необходимо сделать со словом,чтобы получилось:ДЕЛРЕВО



Вы находитесь на странице вопроса "Дана строка. Найти в ней те слова, которые начинаются и оканчиваются одной и той же буквой", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.