Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дана последовательность натуральных чисел a1,a2,...,an. Создать массив из четных чисел этой последовательности.Если таких чисел нет то, вывести сообщение

10-11 класс

об этом факте
Можно на языке Паскаля

Smelov77 27 окт. 2014 г., 11:55:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
3809723157821
27 окт. 2014 г., 13:25:45 (9 лет назад)

Const n=100;
Var a,b:array[1..n] of integer;
I,f,k,j:integer;
Begin
J:=1; f:=0;
For i:=1 to n do begin
Read(a[i]);
If a[i] mod 2=0 then begin f:=1; b[j]:=a[i]; inc(j) end end;
If f=0 then write("net") else for i:=1 to j-1 do write(b[i]," ")
End.

Ответить

Другие вопросы из категории

сколько битов в 1килобайте
ПОМОГИТЕ!!!

Выполните сложение:
а)620,2+1453,3 в восьмиричной СС
б)348,1+234,4 в шестнадцатиричной СС
Выполните вычитание:
а)1100001010-10000011 в двоичной СС
б)1520,5-400,2 в восьмиричной СС
в)368,4-239,6 в шестнадцатиричной СС
Подробно пожалуйста!

+ к карме Задачи по массивам.

Админ зачем ты так делаеш? Человек писал писал, а ты взял и обрубил.....

5 номер решите пожалуйста

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Ребят, выручайте!!! Задание по Pascal. 1. В массиве А[N] занесены натуральные числа. Найти сумму тех элементов, которые кратны данному К. 2. В

целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов.

Дан

массив целых чисел, в котором есть нулевые элементы. Создать массив из номеров
этих элементов.



Вы находитесь на странице вопроса "Дана последовательность натуральных чисел a1,a2,...,an. Создать массив из четных чисел этой последовательности.Если таких чисел нет то, вывести сообщение", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.