Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите разобраться S:=5 for i:=1 to 4 do S:=S+i * 2 Определить сколько раз исполнится тело цикла и чему будет равно

10-11 класс

значение переменной S:

SanjikB 18 нояб. 2014 г., 23:35:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nrusskina
19 нояб. 2014 г., 2:05:34 (9 лет назад)

S = 5

i=1, S=5+1*2 = 5+2 = 7

 

S=7

i=2, S=7+2*2= 7+4=11

 

S=11

i=3, S=11+3*2=11+6=17

 

S=17

i=4, S=17+4*2=17+8=25

 

4 раза исполнится тело цикла и S = 25

Ответить

Другие вопросы из категории

какое значение будет храниться в переменной S после выполнения фрагмента программы:

S:=2;
X:=0;
While x<5 do
begin
S:=S+X;
X:=X+2;
end;
с полным решением пожалуйста.. вроде 4 выходит,но не уверена

Читайте также

Определить сколько раз исполнится тело цикла и чему будет равно значение переменной 1) S:=18 for i:=5 to 3 do S:=S * 2; S:=S+2;

2) S:=15; i:=5. while i<7 do begin i:=i+1 S:=S+S; end

3) S:= -6; i:=4

while i>8 do i:=i+1; S:=S * 0 .

Сколько раз выполнится тело цикла в каждом фрагменте программы?

1. For i :=1 to 7 do S := S + i * i;
2. For x := -3 to 5 do 5 do K := K+ABS(X);
3. For a := 10 downo 2 do P :=P*a;
4. For i := 2 to 6 do
begin
K:=K+1;
S:=K+i;
end;

Сколько раз выполнится тело цикла, и чему будут равны значения встречающихся в программе переменных после выполнения каждого фрагмента программы?

5. i :=2; S:=0;
While S<0 do begib S:= S+i; i:+2; end;

6. x:=1 ; S:=10 ;
While x <=10 do x:=x*2 ;
S:= S+x

7. a:=0; S:=0 ;
While a> 0 do S :=S +a;
a:=a+1;

8 . a:=1;
Repeat
R := 2*a;
a:= a+1 ;
until R < 1;

9. a:=1; b:=1;
While a+b < 8 do begin a :=a+1; b := b+2 end;
S := a+b;

10. S:=0; P:= 10; k:= 1;
Repeat
S:= S+k*k;
k :=k+2;
until S > P;

11. For i :=2 to 6 do begin
K:= K+1; S:= K+i;
end;

12. for i:= 1 to 4 do S :=S+i*i; S: S*2;

Помогите ,пожалуйста,составить блок-схему. Program qqq; Var a:array[0…9] of byte; n,k: integer; j: byte; begin readln(n); for j:=0 to 9 do a[j]:=0;

while n>0 do begin k:=n mod 10; n:=n div 10; inc (a[k]); end; for j:=0 to 9 do if a[j].0 then writeln (j, a[j]); for j:=0 to 9 do if a[j]=0 then writeln(j); end.

1. For i:= 0 to 15 do A[i]:= i+1;

For i:= 0 to 14 do A[i]:= A[i+1]
Задание то же самое, что и в предыдущем.

2. Дан фрагмент программы, обрабатывающий одномерный массив k размером n.
k:= A[i];
For i:= 1 to n-1 do A[i]:=A[i+1];
A[n]:= k;
Что делает данный алгоритм?

Зна­че­ния двух мас­си­вов A и B с ин­дек­са­ми от 1 до 100 за­да­ют­ся при по­мо­щи сле­ду­ю­ще­го фраг­мен­та про­грам­мы:for i : = 1 to

100 doA[i] : = i*i;for i : = 1 to 100 doB[i] : = A[i]-100;Сколь­ко по­ло­жи­тель­ных зна­че­ний будет в мас­си­ве B?



Вы находитесь на странице вопроса "Помогите разобраться S:=5 for i:=1 to 4 do S:=S+i * 2 Определить сколько раз исполнится тело цикла и чему будет равно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.