Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ввести действительные числа x,y,z. вычислить и выдать на печать значение числа m такого что m=max(x,y,z)/min(x-y,x-z,y-z)

10-11 класс

Emma4 29 окт. 2013 г., 12:02:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Asyonok
29 окт. 2013 г., 13:17:53 (10 лет назад)

function mm(x,y,z:real):real;
var
f:real;
begin
if (x>y) and (x>z) then
f:=x
else if (y>x) and (y>z) then
f:=y
else if (z>x) and (z>y) then
f:=z;
mm:=f;
end;

var
x,y,z,m:real;
begin
readln(x);
readln(y);
readln(z);
m:=mm(x,y,z)/-mm(-(x-y),-(x-z),-(y-z));
writeln(m);
end.

Ответить

Другие вопросы из категории

Написать

программу pascal, которая упорядочивает заданную последо­вательность по убыванию с
помощью сортировки обменами. Сортировка обменами заключается в следующем:
просматривается массив с начала и до конца, и каждый раз сравниваются два
соседних элемента A(i), и A(i+1), если A(i)<A(i+1), то они меняются местами. Просмотр массива с начала и до
конца происходит до тех пор, пока все элементы не упорядочатся.

Помогите пожалуйста создать сайт!!

<HTML><HEAD><META http-equiv="Content-Type"content="text/html; charset=windows-1251"><TITLE>Выравнивание и абзацы</TITLE></HEAD><BODY >
</BODY></HTML>
Уточнение<B> </B> Полужирный шрифт<I> </I> Курсив<S> </S> Зачеркнутый текст<U> </U> Подчеркивание
нужно сделать как на фото показано.

Помогите пожалуйста, очень срочно!

Дан массив А , содержащий N элементов .Найти произведение отрицательных элементов массива и их количество. Нарисовать блок-схему. Просчитать значения: N=10 , массив А={-2;0;10;-1;7;3;0}

Одномерные массивы. 3 задачки))

1) Из элементов данного массива W[1..20] создать 2 новых массива, первый из которых содержит только положительные элементы, а второй только отрицательные.

2) Заполнить СЛУЧАЙНЫМИ числами в диапазоне от 1 до 10 два массива A[20] и B[20]. Найти и вывести на экран только те элементы этих массивов и их номера, значения которых попарно совпадают.
Например, если A[2]=B[2]=4, то на экран надо вывести: Номер-2, значение-4.
3) Заменить найденный минимальный элемент числом 100 и показать на экране массив с этой заменой.

Читайте также

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.



Вы находитесь на странице вопроса "ввести действительные числа x,y,z. вычислить и выдать на печать значение числа m такого что m=max(x,y,z)/min(x-y,x-z,y-z)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.