Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскваль Вычислите n чисел Фибоначи:F1=1; F2=1;...;Fn=Fn-1+Fn-2, например: F3=F2+F1=1+1=2,F4=2+1=3 b т.д.

5-9 класс

Anastia0806 16 нояб. 2013 г., 20:44:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Viksten
16 нояб. 2013 г., 21:51:33 (10 лет назад)

var n:longint;

function f(n:integer):longint;

begin

if (n=1)or(n=2) then f:=1 else

f:=f(n-1)+f(n-2);

end;

begin

write("Vvedite poziciu chisla: ");

read(n);

write("chislo ryada na dannoy pozicii ravno ",f(n));

end.

Ответить

Другие вопросы из категории

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число. Программа получает на вход целые числа,

количество введенных данных неизвестно, последовательность чисел заканчивается числом 0. На Паскале

Племя Пульти пользуется 32-символьным алфавитом. Свод законов племени хранится на 512 глиняных табличках, на каждую из которых нанесено ровно 256

символов. Какое количество информации содержится на каждом носителе? Какое количество информации заключено во всем своде законов?

устройства для приема сообщений
постройте математическую модель решения задачи в одной упаковке находиться n керамических плиток размером 33 см на 33 см. сколько

упаковок плитки потребуется для того, чтобы выложеть ею пол в ванной комнате прямоугольной формы размером а см на б см

Читайте также

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел?

Количество? Какое начальное значение должно быть у переменной, в которой накапливаем произведение чисел? Как записывается команда цикла, в которой счетчик цикла уменьшается? Можно ли изменять значение верхней границы цикла в теле цикла? Можно ли в теле цикла использовать команду сравнения



Вы находитесь на странице вопроса "Паскваль Вычислите n чисел Фибоначи:F1=1; F2=1;...;Fn=Fn-1+Fn-2, например: F3=F2+F1=1+1=2,F4=2+1=3 b т.д.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.