Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано число n

5-9 класс

A) напечатать те натуральный числа , квадрат которых не превышает n
B) Найти первое натуральному число , квадрат которого больше n

офигенная21 07 дек. 2013 г., 18:16:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ruppel2004
07 дек. 2013 г., 20:51:56 (10 лет назад)

VAR
   n: Real;
   i: Integer;
BEGIN
   Read(n);
   
   For i := 1 to Round(Sqrt(n))+1 do
      if (i*i <= n) then Write(i,' ')
      else Break;
   Writeln; 
   Write(i);
END.

Ответить

Другие вопросы из категории

В каком случае верно равенство 8+7=3

1.Если это часы на циферблате
2.это 16-ичная систем счисления
3.Такое,невозможно,ни при каких условиях
4.Если это римские числа

ПОМОГИТЕ!!!удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.если таких элементов несколько ,

удалить последний из найденных.Помогите решить в паскале.(вычислить средн.ариф.номер э-та,....)

Читайте также

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Помогите пожалуйстааааа, хотя бы не все но некоторые помогите сделать прошууу:) 1. Перевести данное число из десятичной системы счисления в

двоичную, восьмеричную и шестнадцатеричную системы счисления. а) 113(10); б) 875(10); в) 535,1875(10); г) 649,25(10); д) 6,52(10). 2. Перевести данное число в десятичную систему счисления. а) 11101000(2); б) 1010001111(2); в) 1101101000,01(2); г) 1000000101,01011(2); д) 1600,14(8); е) 1E9,4(16).

1. Перевести данное число из десятичной СС в двоичную СС, восьмеричную и шестнадцатеричную СС. а) 500(10); б) 675(10); в) 810,25(10); г)

1017,25(10); д) 123,72(10)

2. Перевести данное число в десятичную СС.

а) 1101010001(2); б) 100011100(2); в) 1101110001,011011(2); г) 110011000,111001(2); д) 1347,17(8); е) 155,6C(16)

1. Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления А) 273(10) Б) 156,25(10)

2. Перевести данное число в десятичную систему счисления. а) 1100000000(2) б) 1011001101,00011(2) в)1017,2(8) г) 111,В(16)

2) Даны числа от 5 до 78. Заменить все числа кратных 11 на квадрат этого числа.

3) Даны числа от 1 до n. Найти сумму чисел кратных 5, но не кратных 7.
Помогите пожалуйста!!!)))))



Вы находитесь на странице вопроса "Дано число n", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.