Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста решить!!

5-9 класс

Петя распечатал текстовый документ, содержащий 20 страниц,полностью заполненных текстом таким образом, что на каждой странице ровно 30 строк по 40 символов в каждой строке. Для кодирования символов он использовал двухбайтный Unicode. Но Пере понадобилось перекодировать документ, используя однобайтный ASCll, при этом количество строк на странице увеличилось вдвое, а количество страниц и получил объём информации в документе на 31500 Байт меньше, чем в исходном Unicode документе. Определи, сколько страниц нового формата (кодированных в ASCll) удалил Пётр, если они были полностью заполнены символами.

OlgaTis 21 нояб. 2013 г., 14:04:52 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetaboss1
21 нояб. 2013 г., 15:45:04 (10 лет назад)

Пётр удалил 14 страниц. Сначала ноходим общее количество элементов на всех страницах = 24000. Тоесть однобайтовий документ имеет размер 24000б, а двубайтовый 48000б. Если в однобайтовому фаеле изменить число строк на 30, то 30+30 = 60, получаем размер файла 48000. Потом отнимаем от 48000 число 31500, получаем 16500б - это количество символов на тех страницах которые остались. Далее делим на 2400 - количество символов на 1 странице. Мы получили 6 страниц, тоесть 14 страниц Пётр удалил.

Ответить

Другие вопросы из категории

Помогите решить кроссворд СРОЧНО!!!

1)этап подготовки документа на компьютере,при котором вы просматриваете его,исправляете обнаруженные ошибки и вносите необходимые изменения:2)некоторое количество рядом стоящих символов,которые можно рассматривать как единое целое;3)полный набор букв алфавита с общим стилем начертания;4)всевозможные операции по приданию документу вида ,который он будет иметь на бумаге;5)более мощная,чем текстовый редактор,программа обработки текстов ;6)любой текст,созданный с с помощью текстового процессора,вместе с включёнными в него нетекстовыми материалами;7)изменение вида левого и правого краёв документа ;8)выравнивание текста,при котором с обеих сторон каждой строки ширина свободного пространства одинакова ;9)операция над фрагментом с целью его последующего повторения;10)одна из возможных форм курсора

Var k, m: integer; Dat: array[1..10] of integer; Begin Dat[1] := 16; Dat[2] := 20; Dat[3] := 20; Dat[4] := 41;

Dat[5] := 14; Dat[6] := 21;

Dat[7] := 28; Dat[8] := 11;

Dat[9] := 15; Dat[10] := 35;

m := 50;

for k := 1 to 10 do

if Dat[k]<m then

begin

m := Dat[k]

end;

writeln(m);

End.

решите пожалуйста задачи на языке pascal abc net.

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.

Читайте также

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)

Всем информатикам сюда. Помогите пожалуйста,люди добрые...(

1)S=1+2+3...+10
for, while, repeat.

2)S=2+4+6+8...+20

for, while, repeat.
надо короче решить с помощью этих трех программ этот пример. что бы выходил этот ответ...помогите пожалуйста.

помогите пожалуйста! никак не могу с ноутбука зайти в вконтакт, но с телефона получается.появляется (ну это у всех) введите свой e-mail (или

телефон) и пароль .я ввожу, нажимаю войти, потом появляется картинка и говорят "Введите код с картинки" (эту функцию я отключила несколько лет назад!!! ) ,ну я думаю, хорошо, я введу, подумаешь три буковки. ВОТ! После этого проблема. мне пишут " Лена, мы зафиксировали попытку взлома Вашей страницы. Не беспокойтесь, она в безопасности. Чтобы обезопасить Вашу страницу от злоумышленников и в будущем, мы просим Вас подтвердить привязку к телефону и придумать новый сложный пароль. " Ладно я ввожу свой номер телефона, чтоб мне пришел код активации. Раньше мне приходило вот это"Для активации услуги подтвердите Ваше согласие с правилами, Ответь ДА стоимость отправки смс на номер 4012 - 203.19"!!! А сейчас уже если я наберу номер ничего абсолютно не происходит. Ага! Еще чего, не буду я на них целых 200 рублей тратить! Помогите пожалуйста мне решить эту проблему
И еще кое что, когда мой брат или подруга тоже попытались зайти в ВК у них всеё было тоже самое
С телефона пароль меняла, но ничего не изменилось

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "Помогите пожалуйста решить!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.