Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

вычислить 1+2+4+8+...+210

5-9 класс

Нужно написать программу в паскале.

Tomeel76 02 дек. 2015 г., 12:11:47 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Khodkodarya
02 дек. 2015 г., 14:55:31 (8 лет назад)

var a,x:integer;
begin
for a:=0 to 210 do
if (a mod 2=0) or (a=1) then
x:=a+x;
writeln(x);
end.

+ 0 -
Aigulichik
02 дек. 2015 г., 17:13:59 (8 лет назад)

может последнее число 216?

+ 0 -
серёга174рус
02 дек. 2015 г., 17:48:58 (8 лет назад)

Алгоритм:

+ 0 -
Irinkakst78
02 дек. 2015 г., 19:06:04 (8 лет назад)

216=2^8; k:=1; for i:=1 to 7 do k:=k+k*2;

Ответить

Другие вопросы из категории

Паскаль, ввести трёхзначное число

если сумма цифр числа чётная, то увеличить на 2, в противном случае уменьшить на 2

3 В таблице приведены запросы к поисковому серверу, условно обозначенные буквами от А до Г. Расположите запросы в порядке возрастания

количества страниц, которые найдет поисковый сервер по каждому запросу. Ответ запишите в виде последовательности соответствующих букв.

Читайте также

1.вычислите значение логического выражения при всех возможных значениях логических величин X и Y; X или (X не Y)

2.вычислите значение логического выражения при всех возможных значениях логических величин A и B; не(не A или не B) или A
3.вычислите значение логического выражения при всех возможных значениях логических величин A,B и C не(A или B и C) или A
4.вычислите значение логического выражения при всех возможных значениях логических величин A и B; B или не A и не B.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

ПОМОГИТЕ ПОЖАЛУЙСТА С ИНФОРМАТИКОЙ,НУЖНО ОЧЕНЬ СРОЧНО,: (решение задач с параметром,язык PASCAL) №1)дано натуральное n, вычислить:

а) -2/1! +3/2! -...+ (-1)^n *(n+1)/n! (n после единицы это степень)

б) 1!/1+ 2!/ (1+1/2) +....+ n!/ (1+1/2+...+1/n)

№2) дано натуральное n, действительное х, вычислить:

а) x^1 / 1! + x^2 /2+...+ x^n / n!

б)(1/2 - cosx)(2/3-(cos^2)*x)).....( n/(n+1) - (cos^n)* x))



Вы находитесь на странице вопроса "вычислить 1+2+4+8+...+210", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.