Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

При решении использовал функцию power, но преподаватель просит использовать exp. Помогите пожалуйста)

10-11 класс

Hollybolly 18 нояб. 2013 г., 1:05:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cdbltnbkb
18 нояб. 2013 г., 2:34:19 (10 лет назад)

Замените фрагмент с циклом

for i:=1 to n do
   if i mod 2 = 0 then
       s := s -1 / i * (i + 1)
   else
       s := s +1 / i * (i + 1)

+ 0 -
Thyself
18 нояб. 2013 г., 5:09:34 (10 лет назад)

Комментарий удален

+ 0 -
Sura19
18 нояб. 2013 г., 6:46:05 (10 лет назад)

program bab;
var n,i:integer;
s:real;
begin
Writeln ('Введите число n');
Readln(n);
s:= 0;
for i:=1 to n do
s := s + power(-1, i + 1) / i * (i + 1);
Writeln('s=',s);
end.

+ 0 -
Lion78
18 нояб. 2013 г., 7:50:20 (10 лет назад)

Комментарий удален

+ 0 -
Caterina799
18 нояб. 2013 г., 10:06:54 (10 лет назад)

я пытался описывать, как вы написали ранее (a^b = exp(b*ln(a))) но ничего не выходило у меня...

+ 0 -
SweetMary
18 нояб. 2013 г., 12:37:09 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

дан целочисленный массив из 30 элементов.Элементы массива могут принимать целые значения от 0 до 100-баллы учащихся за итоговый тест по

информатике.Опишите на русском языке или на одном из языков програмирования алгоритм, который позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе.
const N=30;
var a: array [1..N] of integer;
i, j: integer;
s: real;
begin
for i:=1 to N do readln(a[i]);
...
end.

Читайте также

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

1)В каких двух форматах представляются числа? В чём разница между ними? 2)Сформулируйте правила записи формул. Что произойдёт, если при вводе

формулы вы нарушите эти правила?

3)Как можно заранее подготовить таблицу для вычислений?

4)Какие вычисления можно проводить над целыми диапазонами?
5) Что понимается под манипулированием с диапазонами ЭТ?
6)Что такое принцип относительной адресации? В каких ситуациях он проявляется?

7)В ячейке D7 записана формула (C3 + C5)/D6. Как она изменится при переносе этой формулы в ячейку? a) D8; b)E7; c)C6; d)F10?

8)В ячейке Е4 находится формула СУММ(А4:D4). Куда она переместится и как изменится при:
А) удалении строки 2;
В) удалении строки 7;
С) вставке пустой строки перед столбцом 6;
Г) удалении столбца 3;
Д) вставке пустого столбца перед столбцом 6;

1)Как в ЭТ реализуется логическая операция при записи условной функций?

2)Что такое абсолютный адрес?

3)Что такое деловая графика?

4)Какой вид имеет условная функция?

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

Задание.Определить, сколько дней осталось от текущей даты до 31 декабря 2013 года: Для ввода сегодняшней даты используйте функцию

СЕГОДНЯ (категория - "Дата и время") Для вычисления разности межлу двумя датами используйте



Вы находитесь на странице вопроса "При решении использовал функцию power, но преподаватель просит использовать exp. Помогите пожалуйста)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.