Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ребята,помогите добавить цикл.который будет генерировать случайные числа,с помощью команды srand.

10-11 класс

Эта программа определяет,возрастающая или убывающая последовательность чисел.

если возрастает,например 1234(1 < 2 < 3 <4 )-то пишет 1
если убывает 321 или 231(3 < 2 < 1)-ложь,пишет ноль
если 111(1 < 1 < 1)ложь,тк строгая возрастающая последовательность,пишет ноль


#include <iostream>
int main()
{
int n;
bool flag = true;
std::cin >> n;
while(n != 0)
{
while (n >= 10)
{
if(n / 10 % 10 >= n % 10)
flag = false;
n = n / 10;
}
std::cout << flag << std::endl;
flag = true;
std::cin >> n;
}
}

NadyaVIP2 04 дек. 2013 г., 9:08:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Khacharoev
04 дек. 2013 г., 9:55:06 (10 лет назад)

#include <iostream>
#include <cstdlib>
#include <ctime>

int main()
{
    int n;
    bool flag = true;
    while(n != 0)
    {
        time(0); //!Рандом каждый раз будет разный
        n = rand() % 1000; //!Собственно, сама рандомизация чисел, будет работать, пока рандом не выдаст число, кратное 1000 (тогда n = rand() % 1000 == 0)
        std::cout << n << std::endl;
        while (n >= 10)
        {
            if(n / 10 % 10 >= n % 10)
            flag = false;
            n = n / 10;
        }
        std::cout << flag << std::endl;
        flag = true;
    }
}

+ 0 -
Rozakosmin
04 дек. 2013 г., 11:38:45 (10 лет назад)

программа написана,просто добавить srand,чтобы сам генерировал последовательность

Ответить

Другие вопросы из категории

дан целочисленный массив из 30 элементов.Элементы массива могут принимать целые значения от 0 до 100-баллы учащихся за итоговый тест по

информатике.Опишите на русском языке или на одном из языков програмирования алгоритм, который позволяет найти и вывести количество учащихся чья оценка за тест выше средней оценки в классе.
const N=30;
var a: array [1..N] of integer;
i, j: integer;
s: real;
begin
for i:=1 to N do readln(a[i]);
...
end.

Читайте также

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))



Вы находитесь на странице вопроса "Ребята,помогите добавить цикл.который будет генерировать случайные числа,с помощью команды srand.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.