Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста. Дано равенство:

5-9 класс

22+55=110
В какой системе оно верно? Ход решения.

Mardanovasamir 24 авг. 2014 г., 4:52:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Echelon30STM
24 авг. 2014 г., 7:13:11 (9 лет назад)

В семиричной СС
22 (7) = 16 (10)
55 (7) = 40 (10)
110(7) = 56 (10)

16+40=56


+ 0 -
Anyutka07spiridonova
24 авг. 2014 г., 8:53:39 (9 лет назад)

Записываем сложение "в столбик".
   2 2
+ 5 5
--------
1 1 0

Рассмотрим сложение в младшем разряде. В десятичной системе счисления 2+5=7, а у нас записан ноль. Следовательно, данный разряд был сброшен, а в следующий добавлена единица. Такое возможно только если сумма (т.е. 7) равна основанию системы счисления, в которой производится сложение. Т.е. мы делаем предположение, что система семиричная.
В самом деле, когда мы складываем два однозначных десятичных числа, например 2 и 8, то получаем 10, 0 в разряде сложения и перенос 1 в следующий разряд. В двоичной система 1+1=10, т. е. тут двойка  (1+1) - основание системы - привела к появлению нуля и переносу.
Проверим предположение, что система семиричная. В следующем разряде снова 2+5=7, но еще есть разряд переноса, итого 8. Но 8 в семиричной системе записывается как 11. Итого получается как раз 110, т.е. система счисления действительно семиричная.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО

Найдите произведение цифр заданного четырехзначного числа...Сделать программу на Паскаль

Петя написал слово кит

Читайте также

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "Помогите пожалуйста. Дано равенство:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.