Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Z(n+2)! Задали вот такое уравнение по информатике,если не ошибаюсь через паскаль нужно его решить,помогите пожалуйста

10-11 класс

Nastaser01 25 сент. 2013 г., 10:23:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мифестофель
25 сент. 2013 г., 12:01:08 (10 лет назад)

var
z,n,i:integer;
f:real;
begin
write ('Z = ');readln(z);
write ('N = ');readln(n);
f:=1;
for i:=1 to z*(n+2) do f:=f*i;
writeln (f:0:0);
readln;
end.

+ 0 -
Uliamaslenchyk
25 сент. 2013 г., 14:29:14 (10 лет назад)

var

  z, x, i: longint;

  f: int64;

 

begin

  write('Z = ');

  readln(z);

  write('n = ');   

  readln(n);

  f := 1;

  for i := 2 to 2 + n do

    f := f * i;

  writeln('Z * (n + 2) = ', z * f);

end.

Ответить

Другие вопросы из категории

1)В

программе описан одномерный целочисленный массив с индексами от 0 до 10. В
приведенном ниже фрагменте программы массив сначала заполняется, а потом
изменяется:

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Читайте также

задание по информатике 2 класс

ИРА , БОРЯ И АЛЁША ЗАКОДИРОВАЛИ ПО
ОДНОМУ СЛОВУ .ВОТ ИХ КОДЫ: ПЕРВОЕ СЛОВО 10111111 10111110 10111011
10110101, ВТОРОЕ СЛОВО 10111110 10110111 10110101 11000000
10111110,третье слово10111011 10110101 11000001.
ПОМОГИТЕ ПОЖАЛУЙСТА.

Русский язык по цене 32р Английский язык по цене 27р 50 копеек Географию по цене на три рубля дороже учебника английского Алгебру по цене 1,5 раза дорож

е учебника по русскому языку.Найти и вывести на экран сумму денег Помогите пожалуйста

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.



Вы находитесь на странице вопроса "Z(n+2)! Задали вот такое уравнение по информатике,если не ошибаюсь через паскаль нужно его решить,помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.